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Introduction To A Microsoft Access
Database

  

1 - Introduction:
 

A database is a collection of information organized as to make it easy to view it, search it, retrieve
the right detail, and collect the necessary facts in an easier, timely, and effortless manner as
possible.

 

2 - Relational Database:
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An organized database is composed of inter-related parts. Since you define these parts, you also
organize them in a manner that helps some parts of your database to supply specific information to
others. In one part, you would cover one category of data, such as people's personal information
(name, date of birth, salary, hobbies, etc), in another you would cover what they buy in a store.

 

3 - Microsoft Access:
Microsoft Access is a relational database used on desktop computers to manage information on
different levels for different purposes.
Microsoft Access can be used for personal information management, in a small business to
organize and manage all data, or in an enterprise to communicate with servers.

 

4 - Database Management System (DBMS):
 

A database is an organized collection of data. Organization means method, it assumes discipline, it
also anticipates efficient manner in using that information. Unless you are creating small
applications for your personal use (and I don't think you are exclusively doing just that), you will
usually need to share your data either with other people (users, DB developers, etc) or other
machines. To make your job easier, Microsoft Access provides in one package the database
information and the tools you need to use your database. To be organized, you will divide your
database in different related parts. The method of management you will use makes Microsoft
Access a Database Management System.
    When you create a database in Microsoft Access, you create a database file that will include
different parts of your database. These are referred to as tables, queries, forms, reports, etc.

5 - Components of a Microsoft Access database:

When you open an instance of Microsoft Access, you encounter the database window, which is the
control point of the different parts of your application.
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From here, you can click an icon to access a specific category, referred to as objects.
Microsoft Access keeps different details about your database in different formats. If you click the
Tables button under the Objects button, you get to the Tables category.

 

Tables:

This is the central point of your development, because all data is stored in tables. The functioning
of your database relies on how you design your tables. For better organization, you will have
various tables in your database, each for a different purpose. For example, for a video club
application, you would use one table to store employees information, another table to store
customers records, yet another table to list different video tapes (their titles, ratings, actors names),
etc.
A table is made of rows and columns.
A row is considered a Record, it is a group of details about one specific item of the table. It could
contain a customer's name, his phone number, his member ID, his work number, his marital status,
etc.
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A column is a field representing one particular category of information about the records in the
table. For example, it would hold the names of all actors in a particular movie, another column
would hold the titles of different movies in the video store.

 

Queries:
A table can be large depending on the information it holds. To further organize your data, you
should be able to retrieve necessary information for a specific purpose. The solution is to create a
query (or queries) so that you will limit part of the data in a table for a specific goal, for better
management or search. That's the role of a query.

 

Forms:
Tables are used to create the data in your database. Sometimes, they are not very cute, as far as the
users are concerned. Forms are windows objects used to view and/or enter data in your database.
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A form can combine data that is part of one or more tables or queries. Forms are the window
interfaces that you usually will ask your users will access when editing data in your database.

 

Reports:
A report in the organized document that you will print from your data. A report can include
different parts or details about your database; it includes data from a table or a query, it could also
get its data from various tables, queries, forms, or data that is calculated from other data coming
from different tables or forms.

 

Pages:
New to Microsoft Access 2000, Data Access Pages allow you to publish your forms as web pages
on the Internet or on an intranet.

 

Macros:
Using Microsoft Access, you can customize certain behaviors of your application. Some of these
behaviors can be automated through a combination of buttons. For example, you might want to
open one document (form) from another. You can use macros to do that; in this case, you would
not have to write code.
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Modules:
Modules are pieces of code used to impose particular behaviors to your application to make it
better. They are written in Microsoft Visual Basic. Modules are more flexible and extensive than
macros, although they are usually written for various and particular circumstances. One example is
to print a receipt after a customer has bought paint in a store.

Macros and Visual Basic code can be used on the same application. Sometimes you will prefer one
to the other, and sometimes you will stick to VBA (Visual Basic for Applications).

 

 

 

 

 

 

 

 

 

 

 

 

 

Creating A Database
1 - Introduction:
Creating a database is, of course, your first concern. The usual problem lies on how and where to
start. The primary decision you will make, and that you will be changing, is the purpose of your
database. What do you expect from the database? Actually, that's the first mistake. The question
is, what do your users expect from this database? If an auto part dealer hires you to design and
create her database, you would spend some time finding out how she wants the software to
behave, what kinds of business partners and customers she has, what information she will be
entering in it, will this same piece of software be used for other purposes besides running her
business (pay roll, appointments, etc)?

Once the business sides have been discussed (normally, this stage will never stop, until you
deliver the final product), you will need to plan your database. At this time, we will not cover
software engineering.

Start Microsoft Access.●   
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2 - Creating a Database from a Template:
Microsoft Access ships with a few sample databases that you can use or learn from (don't hold this
against me but this is an area where MS Access 97 is better than MS Access 2000). To experiment
with one, we will create a database using one of the templates.

Start Microsoft Access. If you just started the application, you will see the starting
Microsoft Access dialog. Click the second radio button; in MS Access 97, it is the Database
Wizard radio button; in MS Access 2000 it is the Access database wizards, pages, and
reports radio button. 

1.  

And click OK. This opens the New dialog.2.  

From the New dialog, click the Databases tab.3.  

From the Databases tab, click Asset Tracking, and click OK.4.  

In the File New Database dialog, type My Personal Resources to replace the suggested File
Name, and click Create.

5.  

After a few seconds, the Database Wizard is ready to guide you in creating your database
project. Click Next.

6.  

The Database Wizard has a few suggestions to create your database. You can examine
them, then add some fields you think are important for your database. For this exercise,
accept only the defaults and click Next.

7.  

For the style of the screen display, choose Stone and click Next.8.  

For the style of the printed report, choose Bold and click Next (if you don't have a printer
installed and connected to your computer, you will not have access to the report features; an
alternative is to install a "fake" printer and make the computer "think" that there is printer;
although you will not be able to print, at least you can preview the reports).

9.  

For the title of the database, type Personal Resources and click Next. Then click Finish. For
a few seconds (sometimes minutes), the Database Wizard will create a database for you.

10.  
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3 - Creating A Database From Scratch:
Creating a database from scratch gives you the
advantage of overall control about your application.

As you might have found out, the (few) templates
shipped with Microsoft Access (2000) cover a very tinny
part of the database issues. This is because they were
provided as samples you could learn and experiment
from. Most of the time, they don't cover what you want.
So, you will have to be a little more creative.
Fortunately, Microsoft Access comes equipped to help
you throughout the whole process.

 
Creating a database from scratch simply means starting from a blank database and adding the
different components.

 

4 - Creating A Blank Database:
If you had already started Microsoft Access, from the Standard toolbar, click the New
button; or from the main menu, click File -> New... This opens the New property sheets.
From the General tab, click Databases (the second property sheet), and click OK.

1.  

If you don't have a database opened yet, start Microsoft Access. From the Microsoft Access
dialog box, choose the Blank Access Database radio button. Then click OK.

2.  

Since Microsoft Access is going to create a file to store the necessary components of your
database, it requires a name. From the File New Database dialog box, in the Save In combo
box, choose one of your drives, for example C:, then click the New Folder icon to create a
folder called Microsoft Access Exercises. Normally, that folder becomes the base folder,
otherwise, make sure that's the folder in your Save In combo box. In the File Name edit
box, type Books as the name of your database. Click Create to create the new database file.

3.  
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5 - Setting Some Startup Options:
To make sure that Microsoft Access always first goes to your favorite folder
whenever you are creating or saving a database, you change the options in the Tools
menu.

From Microsoft Access main menu, click Tools -> Options...1.  

In the General tab, change the Default Database Folder to 
C:\Microsoft Access Exercises.

2.  

Now, download the exercises necessary for this tutorial and install them in C:\Microsoft
Access Exercises. If you are using WinZip, when WinZip prompts you to choose where to
unzip the files, type the path as C:\Microsoft Access Exercises. If you are using a program
like ZipCentral (you can get it free), when the program has finished unzipping the files,
copy or cut all the files (in ZipCentral, on the main menu, click Actions -> Select All). Then
paste the selected files to your default folder which is C:\Microsoft Access Exercises. 

3.  

 

6 - Database Properties:
Whether you work alone or in a group, communication and documentation are important. Your
database project has its own properties that you can use to find out some details about your file, to
enter some notes about the project, or to give directives to other people who have access to the
database.

I know when you created and saved the My Personal Resources database, I didn't specify where it
would be saved. If you too don't remember, let's find out; and while we are at it, let's do some
maintenance work.

From Microsoft Access, if you are not currently running the My Personal Resources
database, click File. A list of most recently opened databases appears. From that list, click
My Personal Resources.

1.  

Once more, from the main menu, click File -> Database Properties.2.  

From the Properties dialog, click the General property sheet. Examine the various sections.
These are self-explanatory. Note and write down the path where the database is located. By
default, it would be C:\My Documents.

3.  
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Click the Summary property sheet. Change the summary sheet to look as follows (besides
the Author and Manager, you can change any item(s) to whatever you like):

   

4.  

Explore the other property sheets and examine what they have to offer. The Statistics tab
gives you statistics about your database and its summary access. The Contents tab shows a
list of the components that are part of your database. The Custom tab shows, and allows you
to customize, the field named associated with your database. When you have finished
working with the database Properties, click OK (if you click Cancel, any change you made
will be discarded).

5.  

On the main menu, click File -> Exit.6.  

 

 

7 - Deleting, Renaming, Or Moving A Database
File:
A database that you create in Microsoft Access is considered a file just like any other files you are
familiar with. This means you can delete it using the same usual process. From My Computer or
Windows Explorer, right-click the file's icon and choose Delete, then confirm or cancel your
intentions.

To rename or move a database file, you have to do it manually. Unfortunately, Microsoft Access
unusually doesn't provide a Save As feature to save a database in a different name. The Save As
menu only renames an object.

Open Windows Explorer (Start -> Programs -> Windows Explorer).1.  
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In the folder you created for your own database projects, right-click Books and choose
Delete. Click No.

2.  

Highlight My Documents or the folder where the My Personal Resources database was
saved. Right-click My Personal Resources and click Cut.

3.  

Right-click the folder C:\Microsoft Access Exercises. and choose Paste.4.  

Right-click My Personal Resources. Click Rename to change the database's name and type:
DCMS.
Press Enter.

5.  

 

 

8 - Exercises:
Using the Database Wizard, create a database based on the Ledger sample. Name the
database Personal Finances and make sure you save it in your default folder. Accept all
fields defaults. For the screen display style, choose International. For the Reports style,
choose Formal. Make sure you specify the database title as Personal Finances. Access the
database properties. In the Comments box of the Summary tab, tell people who access your
database, "Please don't change any of the fields or data in this database. Since this database
is for my personal use, it is important that I keep track of the whole process of designing it.
For any concern, e-mail me (not my mother). Thanks."

1.  

Create a blank database named Georgetown Cleaning Services. 2.  

 

9 - Getting Help In Microsoft Access:
Click the Office Assistant and type: How to create a database?1.  

Click Create a database.2.  

Click Create a database by using a Database Wizard.3.  

After reading, click the Back button.4.  

Click Create a database without using a Database Wizard.5.  

Continue exploring the Help files provided by Microsoft Access. When you finish, close the
help window and the MS Access application.

6.  

 

 

 

 

 

 

 

 

 

 

Introduction To Tables
1 - Introduction:

The Table is the central point of your database. That's why you should and will spend
some time planning, organizing and tuning your tables.

Start Microsoft Access and open the Books database that you created last time.●   
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2 - Creating A Table From Scratch:
You obtain a table from three ways in Microsoft Access: a table can be created from a
template database; you can also use a wizard to create a table; or you can create a table
from scratch. Still, you can use any combination of features and techniques to design
your table(s).

The database window is a little different from Microsoft Access 97 to MS Access
2000.

From the Database Window, click the Tables button if necessary.

The Database Window offers three ways of creating a table. The first option allows you to
create a table from the Design view. If you need help from a wizard, you use the second
button. The third button is used to create a table from the Datasheet view.

1.  

From the Database Window, click New. 2.  

You receive a dialog box offering various ways of creating a table.

  
The Datasheet View allows you to work in a spreadsheet environment with a window made
of rows and columns. The Design View is a little more explicit and detailed, it offers more
control while you are designing your table. Since Microsoft Access comes with a host of
sample tables, you can use the wizard to design and customize your table to suit your needs.

3.  
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On the other hand, you might have a good existing table somewhere either in your computer,
on the network or somewhere else; then you have the choice of importing it or linking to it.
Click Datasheet View and click OK.

You are presented with a window document that looks like a spreadsheet. This is your first
table.

4.  

a) Table Description:

A table is made of various parts to help your creativity.

 

On top of the table, you have columns. These are fields of data. They are originally
named Field1, Field2, Field3, etc. Each column represents one category of information.
On the left side of the table, you have rows that represent records for each item of our
database. Each row has a Row Selector, the gray square; it allows you to select the
whole row.
On the main area of the datasheet, the white rectangles separated by gray borders are
the cells. Each cell is the intersection of a column and a row. Each cell is considered a
field of data.
On the right side of the datasheet, there is a vertical scroll bar. It allows you to move up
and down on your datasheet, this happens if/when your table has more items than can
be displayed all at once, and this will happen (almost) all the time.
There is usually another scroll bar on the bottom right side of the table. It allows you to
move left and right between unseen areas of the table. Finally, the lower left side of the
table is made of five buttons used to navigate the table, and an edit box.

 

The most left button  allows you to move to the first record of the table. The second
button moves you one record back from the current record.  The edit box shows the
number representing the current record. The third button moves you one record ahead.
The fourth button moves you to the last record of the table. And the last button is used
to enter a new record on the table.
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b) Naming The Fields:

Double-click the header of the first field (Field1). When it is highlighted, type BookTitle (in
one word), and press Enter. A field can have almost any name: "Book Title", "This Is The
Book Title", "My Book Titles", etc. Some of your fields will have only tinny data, like a
person's age, the number of books in her office, her MI (middle initial name), etc. So, it might
not be a good idea to give them a name that would take too much space. In the future, when
you start programming, it would be easier to handle field names that are composed of only
one word, without space. Therefore, it is a good idea to stick to good habits. Also, if you are
planning to develop SQL applications or front-end applications that will communicate with a
SQL server in the back (if you are planning to get into this business, that's what you will
certainly be doing), you will have to stick to one-word names, it would make your life
simpler. So, to name a field, first figure out what the data in the category will be made of. If
you are planning to enter employees salaries in a field, you can just call it Salary. If you want
to divide employees names by first name, middle name, and last name, these are the field
names you will use to make them distinct. In this case, you could name the first name field,
firstname (in one word), the last name would be called lastname. Although this good
technique allows you to use one word name, some people including yourself might be
confused. The suggestion is to distinguish wherever a new English (or the language you are
using to design your database) name starts in the field name, by using a starting uppercase.
Instead of firstname, use FirstName. Instead of fullname, use FullName. Instead of
firstdayofmonth, use FirstDayOfMonth. Now, this looks more explicit, doesn't it?

1.  

Double-click the second field and name it CopyrightYear. Change the third field to Author.
The fourth field will be ISBNNumber. The last field will be Publisher.
The table as we have it now is in Datasheet view.

2.  

c) Saving A Table:

On the Standard toolbar, click the Save button to save the current table. A table can have any
name. This time also, there are suggestions made to you. First, the name of a table should
reflect the kind of data it is holding. Second, you can name a table with a few words, with
spaces; but for the same reasons mentioned earlier, stick to a name of one word, without
spaces. The last suggestion recommends that you use a prefix that identifies the table as such,
a table, to reduce confusion. So, instead of naming your table Books, or BookTitles, save it as
tblBooks. Then click OK.

●   

d) The Primary Key:

Microsoft Access needs one more information, actually, this is a suggestion.
We have already seen that a database in Microsoft Access is made of different inter-related
parts. To identify these parts, mainly tables, Microsoft Access needs to have a Primary Key
on each table. When you create relationships between tables in the future, Microsoft Access

1.  
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will need to refer to each table from its Primary Key. There are cases when you don't want or
don't need a Primary Key, this time, we will use one.
So, click Yes and let Microsoft Access create a Primary Key for you.

Next, click the (Design) View button on the Standard toolbar (it should be the most left
button). Now, we have our table on a different view, namely the design view. Microsoft
Access created a Primary Key and called it ID.

2.  

e) Renaming A Field:

If you create other tables and always let Microsoft Access create or set a Primary Key for
you, it will call all of them, ID. Not only this name is not very explicit, but it creates
confusion of its own.
There are also times when you change your mind about the name given to a field. That's why
you should rename that field.
Double-click the name ID and type BookID. Then, press Tab.
The data type of the Primary Key has been identified as an AutoNumber, which means it will
hold a value set automatically by Microsoft Access. In the Description, you can write a
comment that will display on the status bar when somebody, a user, is accessing a field. For
this one, type Automatic number set by Microsoft Access.

1.  

Move to the lower part of the design table.
The data type of the Primary Key will be a Long Integer with incrementing values. For its
caption, type Book ID.

2.  

Click the BookTitle row. Its data type is text, this is the default data type that Microsoft
Access sets for all newly created fields. Since a book title is really a text format, leave it that
way. In its Description section, you can type Title of the book.

3.  

Click the lower part of the view and type Book Title for the caption.4.  

f) A Field's Data Type:

Click the CopyrightYear row on the upper part of the view. Click the combo box of its Data
Type, to display its values.
There are different kinds of data we can display on a table.
A Text represents a group of characters of any kind, but it is limited to 255 characters.
A Memo is used to write a larger text with a maximum of 64000 characters.
A Number is for numeric data.
You use the Date/Time to show date or time.
The Currency is used to represent a currency (money) value.
The AutoNumber sets numeric values automatically.
The OLE Object allows you to include other kinds of files in your database, for example
pictures, graphics, other applications files (Microsoft Word documents Microsoft Excel
spreadsheets, etc).
With the Hyperlink, you can provide a link from your document to a file in your computer or
to a web page on the Internet.
The Lookup Wizard specifies some predefined data on a particular column. These data are
usually prepared by you.
For the copyright year, choose Number; that will represent our years.

1.  

Click the lower part of the view. The field size has been set to Long Integer.
Click the field size combo box to display its values.
A Byte is used for small numbers (integers) that range from 0 to 255.
The Integer (2-byte) is larger than a Byte, it goes from -32768 to -32767.
The Long Integer (4-byte), the Single (4-byte), and the Double (8-byte) represent larger
numbers.
The Replication ID is a 16-byte Globally Unique Identifier (GUID).
You use a Decimal (16-byte) when your number has a decimal value.
For the year, choose Integer. Change the caption to © Year. In the Default Value, delete the
0.

2.  
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If you don't supply a caption for a field, Microsoft Access will use the name that you gave to
the field. In this case, the fields Category and Author are fine; nevertheless, describe the
Author's field as: Author or Authors, Sometimes a Publisher, Like Microsoft Press.

3.  

Click the ISBNNumber field. Although this is a number, it includes - and numbers, but it
usually doesn't cover more that 14 characters, set its field size to 16. Change its caption to
ISBN #. Although it is a good idea to supply an ISBN number or just a number for each book
in our record, we will not make it required. But each book is supposed to have a unique ISBN
number. So, click the Indexed combo box and choose Yes (No Duplicates).

4.  

g) Adding A Field In Design View:

You can add a field in any part of the table in Datasheet View, as well as in Design View.
Click the last row of the upper part of the Design View and type Comments. Set its data type
to Memo.

1.  

To add a field inside of a table, we will add a shelf number to the table as if we were writing a
program for a library. We would like the column identifying the shelf number to be between
the Comments and the ISBN Number fields. To insert a column, click the column that will be
ahead of it, and then click the Insert Rows button on the toolbar.
In this case, click the Comments field; then on Microsoft Access main menu, click Insert ->
Rows. Then type ShelfNumber. Set its data type as Text, and its Description as Number set
by Management. 
Press F6 to move to the lower part of the design view. Set its caption to Shelf #.

2.  

h) Moving A Field:

To move a field, you select it entirely from the Row Selector, release the mouse, then click
again and drag it.
We will move the ShelfNumber field from where it is, to place it between the BookID and the
BookTitle rows.
Place the mouse on the left of the ShelfNumber field, on the Row Selector, until it becomes
an arrow (pointing right), then press it once and release the mouse; this selects the whole row.
Press the same Row Selector again, hold your mouse down, and drag the whole row; while
you are moving, it becomes a (horizontal) line. When the line reaches and corresponds to the
line between BookID and BookTitle, release the mouse.

1.  

On the main menu, click View -> Datasheet View to move to the datasheet view. Microsoft
Access asks you to save the last changes. Click Yes to accept.

2.  

i) Inserting A Field In Datasheet View:

You insert and move fields in Datasheet View the same way you would in the Design View.
This time, you select the column from its header.
To move the Author column, click the Author header once to select it. Click it again and drag
it to be between the ShelfNumber and the BookTitle.

1.  

To insert a new field, click the © Year header column once to select it. From the Microsoft
Access main menu, click Insert -> Column. Now, you have a new field, change its header to
Category.
Good Table.

2.  
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3 - Table In Design View:
 

We should still have the Books database open. Make sure that the Tables button is clicked in
the Objects of the Database Window, otherwise, click it.
From the Database Window toolbar, click the New button to create a new table. This time,
double-click Design View. (In Microsoft Access 97, click the Tables tab in the Database
Window, click the New button, and double-click Design View from the dialog).

1.  

When the Design View opens, in the first row, type BookCategoryID. On Microsoft Access
main toolbar, click the Primary Key button to make sure the current field will be the Primary
Key of this table. Set its Data Type to AutoNumber. In the lower part of the view, set its
caption as Bk Cat ID. Press F6 to go to the upper part of the view.

2.  

Name the second row BookCategory. Set its data type to Text. Set its caption to Book
Category. Index its selection as 
Yes (No Duplicates).

3.  

Save the table as Categories, then close it.4.  

 

4 - Renaming A Table:
You can delete or rename a table easily. If you right-click on it, you make your choice
from the pop-up menu.

We have two tables now: Categories and tblBooks. We would like our tables (and all other
components of our database) to have some harmony.
Right-click on the table Categories and choose Rename. The name Categories becomes
highlighted. Name it tblBookCategories, and press Enter.

●   
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5 - Entering And Editing Data On A Table:
A table can be used to enter data, as long as you have the necessary information as
specified during your design. Of course, you can change data even if it has already
been typed.

Data is entered on a table by typing it in the Datasheet View. The datasheet view looks
like a spreadsheet made of columns and rows. The intersection of a column and a row
is where you enter data, it is called a cell. You can access a cell by clicking in it. To
move from one cell to another, you can use your mouse to click in the desired cell. You
can also press the Tab key on your keyboard. Your keyboard's Enter key has also been
configured to move from cell to cell (in some cases). The arrow keys on your keyboard
can also be used to move between cells.

When entering data in your table, each row represents a record. When you already have
data in a table, you can view it back and forth by navigating in your table. For that
purpose, you will use the necessary buttons at the bottom of the table.

Open the Books1 database.
From the Database Window, click the tblBooks table and click the Open button.

1.  

For the Shelf #, type CS-201-CP and press Enter to move to the next column. The author is
Alan R. Feuer.
For the book title, type MFC Programming and press Tab on the keyboard.
For the book category, type Computer - Programming.
Set the © Year to 1997 and move to the next field.
The ISBN # is 0-201-63358-2. The publisher is Addison Wesley.
For the Comments, type Extensive overview of the Microsoft Foundation Classes libraries..
Press Enter twice.

2.  

Enter one more record.
America A Narrative History is the title of a History book written by George Brown Tindall
And David E. Shi, published in 1996 by Norton, it has the ISBN # 0-393-96874-X, and the
shelf # is HC-001-AA; comment it as Fourth Edition - Volume One.

3.  
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Techniques Of Creating Tables
1 - Introduction:

You will spend most of your time thinking about the functionality of your database.
Although tables mostly work behind the scenes, you need to design and tune them up
carefully. You need a little more organization.
We have already created tables from Datasheet and Data View. What about using
wizards, or importing data from other documents.

 

 

2 - Creating A Database From Wizards:
The wizards in Microsoft Access allow you to use suggested, predefined fields for
your table.. Of course, this doesn't mean that you have to exclusively use the wizards.

Start Microsoft Access and choose to create a Blank Access Database...1.  

Save the database as Music Collection in C:\Microsoft Access Exercises.2.  

 

 

3 - A Simple Table Using The Wizard:
In the Database Window, the Tables button should be pressed already; otherwise, click the
Tables button.
Double-click Create Table By Using Wizard. (If you are using MS Access 97, from the
Tables tab, click New and double-click Table Wizard). The Table Wizard starts.

●   

There is an infinite number of flexible items you can choose from.
Click the Personal radio button (this doesn't mean that the database you are creating is for
personal use, however).

1.  
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In the Sample Tables list box, click Recordings.
To select or unselect a field as part of your table, you can use the four buttons in the middle
of the wizard page. The first button (>) allows you to include the currently selected field in
the Sample Fields. The second button (>>) allows you to include all fields from the Sample
Fields list into your table. The third button (<) unselects the currently highlighted field in
the Fields In My Table list. The fourth button (>>) deselects all fields in the Fields In My
Table list, putting them back where they came from.

2.  

In the Sample Fields, double-click RecordingID.
After you make your choices, you can keep the names provided by Microsoft Access into
your table, or you can rename any field to suit your needs; that's what the Rename Field ...
button is used for.
Since we are creating a music collection database, we want to use a "cooler" name for the
recordings.
In the Fields In My New Table list box, click RecordingID and click Rename Field... Type
AlbumID to rename the field.

3.  

From the Sample Fields, double-click RecordingTitle and rename it to AlbumTitle.4.  

From the Sample Fields, double-click RecordingArtistID and rename it simply Artist.5.  

From the Sample Fields, double-click MusicCategoryID and rename it MusicCategory.6.  

From the Sample Fields, double-click RecordingLabel, rename it to Label.7.  

From the Sample Fields, double-click YearReleased, Format,  NumberofTracks, and Notes.8.  

Click Next.9.  

Name your table tblMusicAlbums, and let the wizard set the Primary Key for you. Click
Next

10.  

Read whatever is on the next dialog, but don't change the default second radio button set for
you. Click Finish.

11.  

Switch to the Design View.12.  

Set the captions of the AlbumID to Album ID, and that of the album title to Album Title.
Change the Data Type of both the Artist and MusicCategory fields to Text. The
MusicCategory's caption will be Music Category.
Change the caption of the YearReleased to © Year.
Change the caption of the NumberOfTracks to Tracks.

13.  

Click the Save button on Microsoft Access toolbar to save your table, then close the
tblMusicAlbums table.

14.  

 

 

4 - Mixing Various Fields In The Wizard:
Microsoft Access is equipped with a flexible table wizard that allows you to create
different kinds of tables, you can even mix fields from different categories.

From the Database Window, double-click the button to Create A Table By Using Wizard.
(If you are using MS Access 97, from the Tables tab, click New and double-click Table
Wizard).

1.  

When the table wizard comes up, click the Personal radio button .2.  

From the Sample Tables, look for and click Categories.
The Categories sample table provides two fields you can select to include in a table.

3.  

In the Sample Fields for the Categories sample table, there are only two choices. Click the
>> button to choose all of them.

4.  

Rename the CategoryID to MusicCategoryID. Then, rename the CategoryName to
MusicCategory.

5.  

You can include any of the sample fields available from other categories.6.  
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To add a new field to our table, click the Business radio button then scroll down in the
Sample Fields until you find the Notes field and double-click it. Then, click Next.

Name the table tblMusicCategories and let the wizard set the Primary Key. Click
Next twice.

7.  

When you have created a table using a wizard, you can still switch straight to the design
view to do more configuration.
In the last page of this wizard, click the first radio button to Modify The Table Design.
Then, click Finish.

8.  

You are switched to the Design View.
Set the MusicCategoryID's caption to Music Cat ID.

9.  

Set MusicCategory's caption to Music Category.
Live the Notes field as is.

10.  

Close the tblMusicCategories table and accept to save it.11.  

 

 

5 - Inserting Fields From The Wizard:
When creating a table from the wizard, you can include and insert fields from any of
the sample tables, sample fields, and categories.

Create a New, Blank Database. Name the new database Employees  and store it in
C:\Microsoft Access Exercises.

1.  

From the Database Window, double-click  
Create Table By Using Wizard.

2.  

In the first page of the Table Wizard, click the Business radio button and choose
Employees from the Sample Tables list box.
From the Sample Fields, double-click EmployeeID, EmployeeNumber, FirstName,
MiddleName (rename it to MI), LastName, Title, Address, City, StateOrProvince (rename
it State), PostalCode (rename it ZIPCode), Country, HomePhone, EmrgcyContactName,
EmrgcyContactPhone, Notes.

3.  

When you are using the wizard to create a table, not only can you include as many fields as
you want, but you also can set any order of appearance. That means you can use fields that
belong to different categories, also you can insert fields anywhere in your list.
To insert a new field where you have already set other fields, you click to highlight the
field that will precede the new field and make your choice from the Sample Table to the
Sample Fields.
Still in the first page of the wizard, in the Fields In My New Table, click Title once to
select/highlight it. In the Sample Fields, double-click WorkPhone, then Extension to
include both and respectively between Title and Address.

4.  

In the Sample Tables, click Customers; in the Sample Fields, double-click EmailAddress to
include it after Extension.
Click Next.

5.  

Name your table, tblEmployees and let the wizard set the Primary Key. Click Next, then
click Finish.

6.  

Open the tblEmployees in Design View.7.  

Set the EmployeeNumber's caption to Empl #.8.  

Set the Extension 's caption to Ext9.  

When you have finished, save and close the table.10.  

Then close the database.11.  
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6 - Creative Processes:
To create your tables, you don't have to stick to one particular process. You can start from the
wizard, add fields in the Datasheet View, switch to and add fields in the Design View, and use the
Build process to add some of the fields available from the wizard.

Create a new Blank Database and name it Silver National Bank.1.  

From the Database Window, in the Tables tab, click the New button. From the New Table
dialog, double-click Table Wizard.

2.  

In the Sample Tables, click Personal, and click Accounts.3.  

In the Sample Fields, double-click AccountID, AccountNumber, and Description.4.  

In the Sample Tables, click Addresses. In the Sample Fields, double-click EMailAddress.
In the Fields In My Table, click Description.

5.  

Click the Business radio button. In the Sample Tables, click Contacts. In the Sample Fields,
double-click FirstName and LastName. Click Next.

6.  

Name the table tblAccounts. Let Microsoft Access Set The Primary Key and click Next.
Click Finish.

7.  

Click somewhere in the LastName column. On the main menu, click Insert -> Column. On
the main menu click Format -> Rename Field and type MI.

8.  

Right-click the Email Address column header and choose Insert  Column. Double-click
Field1 and type Address. Enter.

9.  

Switch to Design View.10.  

Click the FirstName field. On the main menu, click Insert -> Rows. Type Title.11.  

Click the EMailAddress field. On the Standard toolbar, click the Insert Rows button. Type
City.

12.  

Right-click EMailAddress, choose Insert Rows and type State.13.  

Right-click EMailAddress, choose Insert Rows and type ZIPCode.14.  

In the last field under EMailAddress, type Extension.15.  

On the Standard toolbar, click the Build button.16.  

From the Field Builder dialog, click the Personal radio button. In the Sample Tables list,
click Addresses. In the Sample Fields list, click HomePhone and click OK.
  

  

17.  

Right-click Extension and choose Build. In the Field Builder dialog, click the Business
radio button. In the Sample Tables, choose Mailing List. In the Sample Fields, double-click
WorkPhone.

18.  
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Save your table and close it. At this time, you can also close the database.19.  

 

 

7 - Exercises:
The GCS database.

Open the Georgetown Cleaning Services database..  

In Design View, create a table named tblCleaningOrders with the appropriate fields.b.  

Still in Design View, right-click the Pants field and choose to Build a new field
based on OrderDate of the Orders sample table. Rename the field DepositDate and
change its Format to Long Date (people who leave their clothes for dry cleaning are
more interested on the day they left them, rather than on the actual date).

c.  

Right-click on the row selector of the OrderDate field and choose Copy. Right-click
on the Pants field and choose Insert Rows. Right-click the row selector of the new
empty field and choose Paste. Change the name of the new OrderDate field to
RetrieveDate. Close the tblCleaningOrders table.
    

d.  

1.  

The Silver National Bank database.

Open the Silver National Bank..  

In Design View, create a table with AccountTypeID (Primary Key, AutoNumber)
and AccountType. Save the table as tblAccountTypes.

b.  

Create another table called tblTransactionTypes with TransactionTypeID,
TransactionType, and Remarks fields.

c.  

2.  

 

 

 

 

Microsoft Access Tutorial - FunctionX

http://www.functionx.com/access/print.htm (23 of 95) [2000/11/04 09:42:31 AM]

http://www.functionx.com/access/gcscleaningitems.htm


 

 

 

 

 

Introduction To Queries
1 - Introduction:

One of the most important tasks when using a database is to search and retrieve
information. When you create a database, sometimes large tables (though necessary)
don't make your life easy. You need to reorganize your data from the many tables so
that necessary information can be gathered for easy viewing and manipulation.

2 - Definition:
A query is a piece or part of the database created to search for, and retrieve, specific
data for a specific purpose. It can be viewed as a question, or a filter intended to
select only some necessary data.

 

 

3 - Creating A Query From A Wizard:
Start Microsoft Access and open the MPLS1 database.
A query can be created from one table, more than one table, or from another query.
Like a table, a query can be created in many different ways, except that, this time, data
originates from somewhere, mainly a table.

1.  

To create our first query, From the Database window, click the Queries button. Double-click
the Create Query By Using Wizard button. (If you are using MS Access 97, click New,
click Simple Query Wizard, and click OK).

2.  

The first page of the Simple Query Wizard expects you to choose the origin of your query,
starting with the table or the query name. For this example, we will use the tblEmployees
table.

3.  

Then, you choose the necessary data that you want to filter for your query. We want to use
this query to easily retrieve the employees data by either their employee number, their last
name, the date they were hired, their salary, their marital status,  their E-Mail address, or the
city or state they live in. All other information can be used somewhere else.
From the Available Fields list box, double-click EmployeeNumber, Title, LastName,
Function, DateHired, Salary,  MaritalStatus, City, and State. Click Next twice.

4.  

Give the title qryEmployees to your query. Click Finish.
The finished product looks like a spreadsheet, made of columns and rows. Unlike the parent
table, it contains only the data we want to query.

5.  

Now that we have a query, it is time to put it to good use. You can modify criteria or the
behavior of a query in Design View.
Switch to the Design View.

6.  

Under the LastName field, set the Sort orders to Ascending.7.  
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4 - Running A Query:

When your query is ready, you can run it by clicking the exclamation button  on
the toolbar.

To see the results of our query, click the exclamation point button on the standard toolbar.1.  

Switch back to Design View. Delete the Ascending sort the LastName field.2.  

 

 

5 - Query Sorting:
To view employees by seniority in the company, sort the employees in ascending order
under DateHired. And run the query.

1.  

Now, to see the last employee who was hired and other subsequent employees, change the
sort to Descending, under DateHired. Then run the query.

2.  

Switch to Design View and delete the sort retrieval under DateHired.3.  

To see the lowest paid employee in the company, set the sort retrieval to Ascending under
Salary. Then run the query.

4.  

When you are finished inquiring about other people's salary, switch to Design View, and
delete the sort set under Salary.

5.  

You can run a double query. For example, if you want to find out people by seniority (who
was hired first in a certain year), and you want to find out who is earning more among those
hired in a time period, set the sort retrieval under DateHired to Ascending; then set the sort
to Descending under Salary. And run the query.

6.  

Switch to Design View. And delete both sort retrievals.7.  
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Even after you have decided on the fields necessary for your query, you can decide not to
take into consideration a field or some of the fields in your query. To do that, you would
decide not to Show a field.
To see how it is done, click the Show check box under MaritalStatus (so, make sure it is
empty/unchecked). Then run the query. The Marital Status column is absent.

8.  

Switch back to Design View and click the check box to Show the MaritalStatus field.9.  

 

 

6 - Setting Criteria In A Query:
Sorting fields and setting criteria are what makes a query valuable. If you can sort a
field in ascending, descending, or in combination, there are limits to these actions.
The criteria setting allows you be even more specific.

Make sure your qryEmployees query is in Design View.
To see only the people who were hired before 1995, in the Criteria row for the DateHired
field, type <#1/1/96#. This means "show me the people whose DateHired field is less than
January 1st, 1996", which means anybody hired before 1996.
Then run the query.

1.  

Switch back to Design View and delete the criteria set in DateHired.2.  

To find out which employees live Maryland, in the Criteria field for State, type ="MD". Run
the query.

3.  

To find out which ones of the employees don't live in MD, change ="MD" to <>"MD". Run
the query.

4.  

To get the list of employees whose salaries range from $10 to $15, in the Criteria for Salary,
type >=10 And <=15. Run the query.

5.  

Switch to Design View and delete the Criteria set for Salary.6.  

To run the same query, in the Criteria for Salary, type Between 10 And 15. Run the query,
then switch back to Design View, and delete the Criteria under Salary.

7.  

To get a list of married employees (and invite them to the Employees Marriage Conference
of the Greater Washington DC(?!?)), in the Criteria box for MaritalStatus, type True and run
the query.

8.  

Switch back to Design View. To run the same query, replace True with On.9.  

To print a list of married employees, on the Standard toolbar, click the Print button.10.  

To get a list of the employees who hold a function in the company, switch the query to
Design View. In the Criteria for the Function field, type Is Not Null and run the query.
Switch back to Design View. To get a list of employees who don't hold any function in the
company, replace Is Not Null with Is Null and run the query. Switch back to Design View
and delete the criteria.

11.  

Switch to Design View and delete the Criteria set for MaritalStatus.12.  

 

7 - Combining Sort And Criteria:
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The most useful thing about a query is to get the right information and efficiently.
This comes from running a query whose sort and criteria fields have been set
appropriately. Just like you can combine Sort retrieval, you can combine criteria
fields, sort fields, and combinations of lots of them. Sometimes, the purpose is to
narrow your search as much as necessary.

The first thing you need to know about combining fields is that they use Boolean
algebra. Let's review it quickly. If I say, "the dog is in the house", that condition is
TRUE whenever the dog is in the house. If I say, "the dog is in the house and the door
is closed"; that statement is true only if the dog is in the house AND the door is
closed; if the dog is in the house and the door is opened (NOT closed), the statement
is FALSE, the same goes if the dog is outside but the door is closed. If I say, "the dog
is in the house or the door is closed"; if one of these two situations is TRUE even if
the other situation is false, the statement is true. All of that was plain English, wasn't
it? The tricky part lies somewhere else. Mathematicians have had the (silly) idea of
starting some sentences negatively. If in English I say, "the dog is not in the house
and the door is closed"; if the dog is NOT in the house and the door is closed, the
statement is TRUE, but the dog has to be NOT in the house. In Boolean Algebra, that
would be written, "NOT the dog is in the house and the door is closed". I know you
understand it because somebody is just plying with our... mind.

To get a list of employees whose salary is greater than $10 AND live in MD, in the Criteria
for Salary, type >=10; then in the Criteria for State, type =MD (the query will change it to
="MD"). Run the query.

1.  

Switch back to Design View and delete both criteria.2.  

To get a list of the company's employees who earn more than $11 AND are married AND
don't live in Maryland, in the Criteria, for the Salary field, type >=11, for the MaritalStatus,
type True, and for State, type <>"MD". Run the query.

3.  

Switch to Design View and delete all of the preceding criteria.4.  

To get a list of employees who live in Maryland OR in Virginia, for the State field, in the
Criteria row, type MD Or VA, then run the query.

5.  

Switch to Design View. To run the same query, in the Criteria under State, type MD, press
the down arrow key (that should take you to the OR field of the Criteria for State), then type
VA. Run the query.

6.  

Switch to Design View and delete the preceding criteria. Finally, to see an Ascending order
list of employees who live either in Maryland or in Arlington (VA), set the Sort order of
LastName to Ascending; in the OR field for City, type "Arlington"; and in the Criteria field
for State, type "MD". Run the query.

7.  

Switch back to Design View. delete all of the Sort, Criteria, and OR fields. Run the query.
Make sure you have all data.

8.  

Save the qryEmployees query and close the database.9.  

 

8 - Getting Help In Microsoft Access:
Click the Office Assistant and type Query.1.  

Click Create a query.2.  
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Introduction To Forms
1 - Introduction:

The form is the component that will link you to your users , this is where they will do
most of their work. While tables  are working behind the scenes, your users don't see
them, in fact, you can make sure they don't manipulate them to prevent them from
changing anything concerning the functionality of your database. Nevertheless, your
forms depend on tables and queries.

Forms are designed for various purposes. Some forms can be used to enter data,
which is their primary and most usual purpose. you can use other forms for data
viewing only because sometimes you don't want some users or inappropriate users to
modify the content of a database. Some other forms can be designed as intermediate
dialogs between other forms, for example, you might want to make sure that a user
performs a certain operation before she can open another form; otherwise, you would
not make the second form available. Another form can be used as a printing directory,
the point where users decide what to print and how.

2 - Forms Overview:
Since there are many things you can include in a form, there are also various ways
you can create them. A form can derive from a table or a query. In fact, a form can
come from various parts of different tables. Also a form can be used to calculate
variables derived from other parts of the database.

You can control the features of your form by including controls from the toolbox.

When creating a form, you have a lot of choices from where to start. This time again,
you can use a wizard to create a form, you can also create a form from Design View.
You can insert a form in your application by going through the Insert -> Form menu.
The New Object button on the standard toolbar provides a way of creating a form
using either the  AutoForm or the Form choices.

Whenever you want to create a form, the first decision you make is to tell Microsoft
Access where data is coming from. As a  form can be created from one or more
tables; it can also originate from one or more queries. A form can also use a
combination of tables and/or queries. If data is originating from more than one
source, you have to create relationships among those sources, or make sure that they
are related.
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3 - Forms Layout:
Forms can be designed in at least four flavors: Columnar, Datasheet, Tabular, and
Justified.

The most popular of them, a columnar is a form made of labels, edit boxes, combo
boxes, etc. A datasheet form looks like a spreadsheet, it is made of rows and columns
separated by gridlines. A tabular form looks like a datasheet form except that it is
made of "physical" gridlines whose dimensions you can modify. A justified form is
the cousin of the columnar  and the tabular forms 

A form is made of labels, edit boxes, combo boxes, graphics, and other control
items...

 

4 - Creating Forms - Columnar Forms:
a) The Microsoft Access AutoForm Feature:

You can create a form easily by using the AutoForm feature once you have a source
that will provide all the necessary information.
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Open the Books2 database.1.  

From the Database Window, under the Objects bar, click the Tables button, then click the
tblBooks table once to highlight it.

2.  

On the Standard toolbar, click the New Object:AutoForm button.3.  

4.   A form based on that table is automatically created for   
      you.
5.   When you have finished looking at the new form, save it 
      as frmBooks.
6.   Close the form.

7.   Use the AutoForm feature to create a form based on the
      tblBookCategories table. Save the form as
      frmBookCategories.

b) Creating A Form From Wizard:

To create a form using the form wizard, you decide the origin of data and the field
necessary for your form.

From the Database Window, click the Forms Object button. Then double Create Form By
Using Wizard.

●   
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The first page of the form wizard allows that you choose the originating table or
query that will supply the necessary fields in the form.

From the Table/Queries combo box, choose the tblBooks table.1.  

From the Available Fields: list box, you can select all fields or decide which ones you want
to include in the form.
From the field list, double-click ShelfNumber, Author, BookTitle, CopyrightYear, and
Comments.
Then, click Next.

2.  

Accept or choose the Columnar layout, then click Next.3.  

Choose the Standard style and click Next.4.  

Name your table wfmBooks and click Finish.5.  

 

6 - Deleting Forms:
Just like a table, you can delete a form if you don't like the way it looks, or for some
reason it doesn't accomplish the desired purpose. You just right-click it in the
Database Window and choose Delete, then confirm. You can also highlight it in the
Database window and press the Delete Key on the keyboard.

With the Books3 database still opened, from the Database Window, click the Forms object.1.  

Right-click on the wfmBooks form and choose Delete from the popup menu. A
warning/confirmation message will allow you to change your mind. Click No.

2.  

With the wfmBooks form still highlighted, click the Delete key on the keyboard and make
your decision whether to delete it or not.

3.  

Now you can close everything.4.  
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8 - Help In Microsoft Access:

  

Click the Office Assistant and type: Create a Form.1.  

Click Create a form.2.  

Click Create a form on my own.3.  

Click See examples of what forms are and how they work.4.  

Click the small graphic and view.5.  

 

 

Introduction To Reports
1 - Introduction

If tables are used as the platform where you design your database and forms are used
to provide a cute visual interface to your user when they are viewing your creativity,
reports are the focus of your printing needs. Although you can print from tables,
queries, or forms, they lack the formatting features available to reports.

By the way, if you don't have a printer installed and connected to your computer, you
will not be able to work on this lesson. The alternative is to install a "fake" printer so
that Microsoft Access will "think" that you have a printer and allow you to do your
exercises. If you can't print, at least you should have an idea of what you are doing, by
using the print preview.

 

 

2 - Definition:
A report is used to prepare a special document for printing. All the visual effects and
features that you want people to see on printed paper from your database will be
designed in report documents.

A report can be designed in many ways using wizards or almost from scratch.

Like a query or a form, a report uses data provided from a table, many tables, a query,
many queries, or calculated fields. Once you have the originating data, you can use
the wizard to create your form, or can design your form in Design View.

 

Microsoft Access Tutorial - FunctionX

http://www.functionx.com/access/print.htm (32 of 95) [2000/11/04 09:42:31 AM]



3 - The AutoReport: Columnar:
Start Microsoft Access and open the Videos1 database.1.  

From the main menu, click Insert -> Report.2.  

In the New Report dialog box, choose AutoReport: Columnar and tblActors as the
originating source of data. Click OK.

3.  

After a few seconds, a report based on the tblActors is created for you. Now you have a
printable report. Save it as rptActors, then close it.

4.  

 

4 - The Auto Report: Tabular:
In the Database Window, click the Reports button.1.  

On the Database Window's toolbar, click the New button.2.  

In the New Report dialog box, choose AutoReport: Tabular and in the  table/query combo
box, choose tblVideoCategories as the originating source of data. Then press Enter.

3.  

Once the Office Assistant has finished dancing, you will have a tabular report. Save it as
rptVideoCategories.

4.  

Close the rptVideoCategories report.5.  

 

5 - Report From Wizard:
A report using the wizard involves a little bit of your participation, you have to make a few
decisions.

Click the New Object button on the toolbar and choose to create a report.1.  

In the New Report dialog box, choose Report Wizard and in the  table/query combo box,
choose tblVideos as the originating source of data and click OK.

2.  

In the first page, choose to include all fields to the report, then remove the Notes field, and
click Next.

3.  

If the report wizard adds a grouping level for you, remove that blue field as the group
header. Then click Next twice.

4.  

For the Layout, choose Tabular; for the Orientation, choose Landscape. Click Next.5.  

Choose the Bold Style and click Next.6.  

Save the report as rptVideos and click Finish.7.  

View the report in Print Preview, then close it.8.  

Finally close the Videos1 database.9.  

 

7 - Getting Help In Microsoft Access:
Click the Office Assistant and type Reports.1.  

Click Create a report.2.  
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Data Access Pages
If you are using Microsoft Access 97, skip this section.

1 - Introduction:
A Data Access Page is a form you create for users on the Internet using a browser.
Your can accommodate you users and/or visitors with a convenience application they
simply have to fill out. The form also has a lot of functionality and flexibility.

There are different ways you can create a Data Access Page, using a click of the
mouse, using a wizard, or design a better one.

Like a query, a form, or a report, a Data Access Page gets its fields from an existing
table or query. You can also modify an existing web page to design your Data Access
Page.

2 - Creating An AutoPage: Data Access Page:
Start Microsoft Access and open the Videos1 database.1.  

In the Database Window, click the Pages button.2.  

On the toolbar, click the New Object button to drop its list and choose Page.3.  

In the New Data Access Page dialog, choose AutoPage: Columnar. In the table/query
combo box, choose tblVideos and click OK.

4.  

A quick and cute page is created for you. Save the page as dapvideos, and close it.5.  

3 - Opening A Data Access Page:
There are two ways you can preview your Data Access Page. Using Windows
Explorer to launch the page or opening it from the browser.

Open Windows Explorer, locate the folder where your databases are located (where the
page was saved), this should be C:\Microsoft Access Exercises and then double-click
dapvideos.htm. That should call your default browser and show the page you created.
If the browser is already opened, click File -> Open... Then browse the hard drive, different
drives and folders, then open the dapvideos web page.

1.  

In the browser, click the New Record button and enter the following records:
  

VideoID (AutoNumber)
VideoTitle Under Siege
VideoCategoryID 22
Director Andrew Davis
ReleasingCompany WB
YearReleased 1992
Rating R
Length 103 Min

    

2.  

When you have finished, close the Videos2 database.3.  
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4 - Creating A Data Access Page From Wizard:
You can create a quick Data Access Page using the wizard and allow people to use it
on the Internet.

Open the Greater Highland High School database (GHHS).1.  

In the Database Window, click the Pages button.2.  

Double-click Create Data Access Page By Using Wizard.3.  

In the first page, choose Table: tblStudentRegistrations. Select all fields and click Next.4.  

Make sure items are not in any grouping, in other words, you should have a complete
blank/white list/paragraph of the table's items on the right list (no blue item on top). If you
happen to have a grouping of items, remove the header of the list.

5.  
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Click Next, Next. Save the page as dapStudentRegistrations and click Finish.6.  

Make sure you are in Design View. On top of the page, click the Click Here And Type Title
Text line, then type:
Online Student Registration.

7.  

Save the web page as dapregistrations.8.  

Open the page in your browser and edit some records.9.  

Then you are free to close everything.10.  

 

Exercises:
The DCMS, Inc.'s Business Resources database.

Open the DCMS database..  

Press F11 to access the Database Window.b.  

Double-click the Asset Categories table to open it in Datasheet View. Type the
following asset categories: Desktop PC, Bookshelves, Furniture, Car, Copier.

c.  

Open the Status table and type the following: In Service, On Repair, Inactive,
Non-Existing.

d.  

Open the Employees table. Move the Extension right of the WorkPhone field. Make
the following entries:

FirstName LastName Title WorkPhone Ext Ofc Loctn
Daniel Sherrer IT Supervisor (202) 622-7985 24 42C
Cynthia Briggs Accountant Ctrl + ' 22 40A
Maurice Kumar HR Coordinator Ctrl + ' 25 41C
Brigitte Adeyemi Dir Of Sales Ctrl + ' 28 42A

e.  

 f.  

1.  

 

Help In Microsoft Access:
Click the Office Assistant and type Data Access Pages.1.  

Click Create A Data Access Page.2.  
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Controlling The User's Input
1 - Introduction:

Redundancy in database is the default of having the same data provided or entered in
more that one component; having two different forms from where the user can enter
the same customer's name is nasty is should always be avoided. Furthermore, when
you design your database and decide that some boxes will receive an employee's date
of birth, you have to make sure that only a recognized date can be entered.

Different components of your database are meant to communicate and collaborate,
allowing some data in one component to supply necessary data to another; this
assures that the same data cannot be entered from more than one place, once more
eliminating redundancy.

  

2 - Input Masks:
Microsoft Access comes with input masks allowing you to controlling user's input such as dates,
times, Social Security Number, Currency values, etc.

Start Microsoft Access and choose to create a blank database called Ashburn Agency.1.  

In Design View, create a table with the following fields:
  

Field Name Data Type Caption
EmployeeNumber (Primary Key) Text Empl. #
FirstName Text First Name
MI Text MI
LastName Text Last Name
DateHired Text Date Hired
Salary Text Salary
SSN Text Soc. Sec. #
Title Text Title
MaritalStatus Text Married?
WorkPhone Text Work Phone
Extension Text Ext.
FavWebSite Text Fav. Web Site
Notes Memo Notes

2.  

Switch to Datasheet View and save the table as tblEmployees.3.  

In the Employee # field, type dot and in the Salary field, type Suzy and press Enter.
Microsoft Access has accepted your entries and is ready for another record, the only
problem is that if in your company you have employee's numbers formatted and called dot
and whatever and a table or form accepting a name in a field reserved for money, you
might end up getting confused about employees and on pay day, somebody will not receive
her wages. These are the things we will avoid from data entry.

4.  

Switch to Design View.5.  

Click the Salary field. Set its Data Type to Currency and delete the 0 set as its Default
Value. The data you left in the Datasheet View will be deleted when you save the table.

6.  

In our records, we only want to know whether an employee is married or not. To get that
result, the user will choose between a Yes or No. Set the Data Type of the MaritalStatus to
Yes/No.

7.  

One of the Data Types provided by Microsoft Access allows you to specify a field for a8.  
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date or time values. Click the DateHired field. Change its data type to Date/Time. In the
lower part of the Design View, change its Format to Short Date.
Save the table.
You can built an input the way you want data in that field to be formatted. Or, you can use
the Input Mask wizard to assist you in building your mask.
Click the Input Mask field. There appears an ellipsis/build button on its right, click that
button. When the Input Mask Wizard comes up, choose Short Date. Click Next twice and
click Finish.

Most companies and institutions give telephone extensions in the form of a two, three or
four-number format. Let's imagine that our company here uses an extension like 4266. This
is a number made of four characters. So, specify the Extension's Data Type as Number. In
the lower part of the design view, change its field size to Integer. To make sure that the user
will not enter a value like 3,528, set its Format to General Number. Set the Decimal Places
to 0 zero.
Unfortunately, the user can still type a number like 218 or 54 for the extension, that would
not abide to the rules of our company here. To make sure that the user can only type a
four-character number, in the Input Mask, type 0000. As it happens, 0000 tells Microsoft
Access that the user will not be allowed to type anything else than four digits, which means
you can reset the Extension's Data Type to Text.

9.  

The Input Mask is very useful when you want to control what your users type. Most
institutions would accept just one letter for the middle initial name. If you use our table
now and type something in the MI field, it would accept anything. If you want to limit the
user to enter only one character, you can save space on your table and eventually on your
form by allowing only one letter in that field.
Click the MI field and set its field size to 1. Unfortunately, the field can still accept a
number, and we know that nobody has a middle name as 3, 8, or 5.
To limit the entry to one letter only, type L in the Input Mask. The other extra thing you can
do is ask Microsoft Access to convert to upper case any letter entered in the MI field. To do
that, just type > in the Format field.

10.  

The Validation Rule field allows you to specify the standard that will recognize whether the
user type a correct entry in an appropriate field. And you can write the write message to
indicate the error to the user.
Every bank has a set of rules on how its bank accounts are formatted, in the same way
different companies use different formats for their employees numbers. Since we have
already seen how you can set a field to use only numbers or letters, let's use a different
formatting for our employees numbers.
Let's say our company has decided that an employee's number will display like ED-4577-G.
This number uses two letters separated by a dash, underscore, or a hyphen, followed by
four number, then another separator and ending with one letter.
To accomplish that, you can specify the properties of the employee number field like the
following:

If you use that formula, the data entry personal will have to keep in mind how employee's

11.  
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numbers are formatted or formulated. On the other hand, there is a better way of formatting
the employee number and at the same time helping the data entry employee by providing
masks.
For the employee field, delete the formula you entered in the Validation Rule and, in the
Input Mask, type the following:
LL\-0000\-L0;0;_
This formula assures that two letters and strictly two letters will be typed first, followed by
a dash, followed by four digits, then a dash, and finally one letter and one digit. Save the
table.

To control telephone number entry (in the US and Canada), click the WorkPhone field. In
the lower part of the Design View, click the Build button of the Input Mask. In the first
page of the Input Mask Wizard, choose Phone Number and click Next twice. In the third
page click the first radio button to allow the user to see parenthesis and the dash sign while
he is typing the value. Then click Next and click Finish.

12.  

Change the Data Type of the FavWebSite to Hyperlink. 13.  

 

3 - Validating Entries:
While you are trying to control valid entries, you can decide what Microsoft Access will accept as
an acceptable value. You can set ranges of acceptable values and direct the user to what is correct.

As we are still in the Design View, we will now set the minimum wage in the company. Let's say
the salary in the company starts at $6.45 and nobody should earn less.

If you want to specify a date as a text, you enclose it between pound (#) signs. For example, let's
say this company was created on 24 January 1984. There is no way anybody could have been
hired before that date.

Click the Salary field. In its Validation Rule field, type >=6.45 and press Enter.1.  

In the Validation Text, type The minimum wage in this company is $6.45.2.  

Click DateHired. In the Validation Rule, type >= #1/1/84#.3.  

In the Validation Text, type Come On, no one was hired here before January 1st, 1984.4.  

4 - Setting Items For A Preset List:
You can furthermore control the user's input by presetting some values so that he can
only choose what is available, in the form of a combo box (or a list box).

Click the Title field. For its Data Type, choose Lookup Wizard...1.  

When the first page of the Lookup Wizard comes up, choose the second radio button telling
the wizard that you will type values for the field, then click Next.

2.  

Under Col1, type Ms., then press Tab, type Mr., the third field will be Mrs., then Dr., Prof.,
Sir, Rev., Rabbi, Fong, Other.
Click Next. Accept the column label as Title and click Finish.
Click the Lookup tab in the lower part of the Design View and see the work that was done
behind the scenes. To make sure that the user can only choose a preset value in the list, set
the Limit To List field to Yes; on the other hand, if you want to allow the user to type new
entries, you would set Limit To List to No (keep in mind that even if you restrict the user to
choose only from the list, you yourself can eventually modify that list).

3.  

Save the table, then close the Ashburn Agency database.4.  
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5 - Getting A Field's Data From Another Source:
Using the wizard or working manually, you can make sure that there are fields that will receive
their data from another table, once more this reduces redundancy of data.

Open the Books3 database.
Imagine that you work for a public library where books are categorized in a certain order. It
is better to make sure that the new books registered follow the categories that have been
preset, this reduces confusion. We will then make sure that the book categories originate
from the book table.

1.  

Open the tblBooks table in Design View.2.  

Click the Category field to highlight it.
Press Tab to move to the Data Type area.
Press L and press F6. 

3.  

When the first page of the Lookup Wizard comes up, accept the first radio button and click
Next.

4.  

You then have to choose which table or query holds the originating data. Right now we
have only one table, so it is chosen by default; otherwise, you would choose
tblBookCategories and click Next.

5.  

You can include many fields for a particular column, except that only one will be seen
when its combo box is not dropped.
For this example, only the BookCategory is needed (Microsoft Access will include the
other, even if you don't select it). So, double-click BookCategory and click Next.

6.  

Agree to let Microsoft Access Hide The Primary Key and click Next.
Accept the Category label for the column and click Finish.

7.  

Accept to save the table.
When the wizard finishes, it should take you to the lower part of the view because you
clicked F6 before starting the wizard.
Delete the Default Value of 0 (zero).
If you want to see what Microsoft Access did behind the scenes to get the lookup values,
click the Lookup property sheet.

8.  

Save the table and switch to the Datasheet View to verify that the Category field has a
combo box now and doesn't allow any value that is not coming from the tblBookCategories
table.

9.  

Specify the Category of MFC Programming as Computer - Programming. The Category of
America A Narrative History is History.

10.  

When you have finished, close the tblBooks table and close the Books3 database.11.  

6 - Extra Stuffs:
Here are some formulas you can use to control user's input.

Name Input Mask
USA/Canada Phone # !(999) 000-0000;0;_
Cameroon Phone # !"(237) "00\-00\-00;0;_
5 Digit US ZIP Code 00000
US Complete ZIP Code 00000-9999;0;_
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7 - Exercises:
Creating tables for the Georgetown Cleaning Services database:

Open the Georgetown Cleaning Services2 database..  

In Design View, create a table named tblCustomers. Give it the following field
names:

Field Name Data Type Caption Input Mask
CustomerID
(Primary Key)

AutoNumber Customer ID  

CustomerName Text Customer Name  
CustomerPhone Text Customer Phone !\(999") "000\-0000
Notes Memo    

b.  

Using the Table Wizard, create another table named tblEmployees. From the
Employees Sample Table, select the following fields: EmployeeID,
EmployeeNumber, FirstName, MiddleName (rename it MI), LastName, Address,
City, State, PostalCode, Country, HomePhone, EmailAddress, WorkPhone,
DateHired, Salary, EmrgcyContactName, EmrgcyContactPhone, Notes.

c.  

Open the tblCleaningOrders table in Design View. Insert a new filed after OrderID
and name it Clerk. Using the Lookup Wizard, make the Clerk field get its data from
the tblEmployees table; at this time, we will need only the LastName.

d.  

Add another field after the Clerk field and name it Customer. Using the Lookup
Wizard specify Customer's data as provided by the CustomerName field from the
tblCustomers table.

e.  

 

1.  

Improving the Silver National Bank database

Open the Silver National Bank2 database..  

On the Database Windows, click the Tables button.b.  

Open the tblAccountTypes table and type Checking then Saving, and finally CD for
the account types. Close the table.

c.  

Open the tblAccounts table in Design View. Change the Input Mask of the
AccountNumber field to read: 000\-000\-00.

d.  

Using the Lookup Wizard, specify the AccountType as getting its data from the
tblAccountTypes table (select only the AccountType field).

e.  

Using the Lookup Wizard, specify that the titles will come from the list that you are
going to provide. The titles are: Ms. Mr. Mrs. Dr. In the lower part of the Design
View, in the Lookup tab, specify the Limit To List to Yes. Set the default value of
the Country to USA.

f.  

Switch the tblCustomers table to datasheet view. Fill it out as follows: DateJoined:
02/24/95; AccountType: Checking; Account #: 312-874-39; Title: Mrs.; First Name:
Gertrude; MI: C; Last Name: Waters. Address: 4288 S. Patton St; City: Colesville;
State: MD, ZIP Code: 20912.

g.  

The next account is, DateJoined: Ctrl+'; Account #: 576-873-47; Account Type:
Saving; Title: Dr.; First Name: Steve; Last Name: Yacobby; Address: 3901 Georgia
Blvd; City: College Park; State: (press Ctrl + ', that will paste MD from the former
State entry), ZIP Code: 20707.

h.  

2.  
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7 - Getting Help In Microsoft Access:
Click the Office Assistant and type Input Mask.1.  

Click Create an input mask to control how data is entered in a field or control. Then
proceed.

2.  

Click the Office Assistant again, and type Validation Rule.3.  

Click Validation Rule, Validation Text Properties.4.  

Click the Office Assistant again, the last entry should still be there.5.  

Click Validate or restrict data entry in tables.6.  

Proceed to the choice that fits your current situation.7.  

Relationships And Subdatasheets
1 - Introduction:

The concept of relational database insures data reliability on the foundation of data
moving from one source to another. There are many goals behind this concept. Data
in your resources needs to be as much accurate as it can be. Provided your database
is made of various components, mainly tables, you should avoid any redundancy
possible, in other words, data from one source should be unique and almost never
duplicate.

To accomplish these goals, you interrelate the various components of your database,
namely tables (remember, and as you will see later, data in your database depends
on, or is originating from, your tables). 

2 - Relationships:
Open the Music Collection 2 database.●   

When creating various tables in your database, if your first goal is to get necessary
data, the second would be to provide accurate data. To succeed in that, you build
relationships between and among tables so that they will collaborate and provide
necessary data to one another.

Building tables relationships is one thing, controlling these relationships is another.
This is where your efficiency in avoiding redundancy is revealed. For one table to
provide data to another, each one of them should have unique data that the another
table needs.

When you are creating a Lookup field, you are telling one table that the value
entered in this particular field will come from another table, and you specify the
originating table. The originating table is the parent table, the target table is the child
table.
The reason you established Primary Keys in your tables is because these are the
fields used to build relationships between tables. They are used to verify the
uniqueness of data. Also, they avoid that data in relationship get mixed. You can
build a reliable relationship only between data of the same kind.

Click the Relationship  button on the toolbar. The Show Table property sheet comes
up. From here, you will specify what tables (or queries) will be used when building your
relationship (s). Click the tblMusicCategories once and click the Add button. Double-click
the tblMusicAlbums; finally include the tblMusicTracks.
Close the Show Table property sheet. Arrange the layout of your relationship window so
that the  tblMusicAlbums table be in the middle of the tblMusicCategories table on its left
and the tblMusicTracks table on its right.

1.  

Microsoft Access Tutorial - FunctionX

http://www.functionx.com/access/print.htm (42 of 95) [2000/11/04 09:42:32 AM]



The originating table uses its Primary Key and associates it to the field you choose in the
target table. The target field is referred to as the Foreign Key.

Drag the MusicCategoryID field from the tblMusicCategory table to the MusicCategoryID
field in the tblMusicAlbums table.
The Edit Relationship dialog comes up. This allows you to confirm creating a relationship.

Click the Create button to create the relationship.
Now you have a line relating these two tables.

2.  

Drag the AlbumID field from the tblMusicAlbums table to the AlbumID in the
tblMusicTracks.

When manipulating data that is in a relationship, it is very important to make sure that data
keeps its accuracy from one table or source to the other, to succeed in that purpose, you
need to Enforce Referential Integrity so that when you change data in the parent table, data
corresponding in the child table be changed/updated also; this is done through Cascade
Update Related Fields.
On the other hand, the Cascade Delete Related Records helps to delete data in the child
field when the corresponding data has been deleted in the parent field.
The relationship you establish between two tables creates a Subdatasheet which is a child
table related to the parent table.

3.  

Click the Enforce Referential Integrity check. Now, the database would like to know how
you will handle data updating and deletion.
Check all the three check boxes, and click the Create button. 
Now you have a 1 on the parent field and the infinity sign on the child field. The 1 (One
side relationship) means that the originating field, the parent, supplies the data that changes
the value in the target. The infinity symbol (¥) means that many fields in the target table
are affected by the data coming from the parent table.

4.  

Right click the relationship line between the tblMusicCategories table and the
tblMusicAlbums table, then choose Edit Relationship... from the popup menu.

5.  

Click all the three check boxes.
Click the Join Type button.

6.  

The Join Properties dialog allows you to specify the direction of the relationship.
Click the second radio button that will allow the parent field in the tblMusicCategories to
control the corresponding and related fields in the tblMusicAlbums.
Click OK twice.
Now you have not only the one-to-many sign, you also have an arrow reminding that data
in the MusicCategory field of the tblMusicAlbum will come from the MusicCategory field
of the tblMusicCategies table.

7.  
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When you are finished with the Relationship Window, save and close it.8.  

If you are using Microsoft Access 97, skip this Subdatasheet section.

3 - Subdatasheets:
A subdatasheet is a sheet of data that you include in a parent table to allow you to
view related data in order to have it handy.

You can insert another table or a query to an existing table as a subdatasheet as long
as these two can exchange data through a relationship. For example, in our music
collection database, when viewing the tblMusicAlbums table in Datasheet View, it
would be helpful for the user to view the tracks that are part of an album. To make it
happen, you can include a child table as a whole table or create a query that isolates
necessary data and then insert the query as a subdatasheet.

Now that we have created necessary relationships in our database and eliminate
redundancy, let's implement the concept of subdatasheet. To do that, we will include
the tblMusicTracks table into the tblMusicAlbums. Since the tblMusicTracks table
has the TrackID and the Notes fields that we don't need to display in our new table,
we will isolate them (we will still need them in their own table). Thus, let's create a
small and quick query.

 
From the main menu, click Insert -> Query.1.  

From the New Query dialog, double-click Simple Query Wizard.2.  

From the first page of the wizard, in the Tables/Queries combo box, choose the
tblMusicTracks table.

3.  

Click the >> button to select all fields. Then click the < button (remove button) for the
Notes field to remove it.
(Now we have the TrackID, AlbumID, TrackNumber, TrackTitle, and Length fields only)

4.  

Click Next -> Next. Name the query qryMusicTracks. And click Finish.5.  

Close the new query.6.  

 
Now we will insert the qryMusicTracks query in the tblMusicAlbums as a
subdatasheet.
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From the Database Window, double-click the tblMusicAlbums table to open it in Datasheet
View.

1.  

From the main menu, click Insert -> Subdatasheet...

  

2.  

The Insert Subdatasheet property sheet allows you to choose which object to include in
your table. That object can be a table or a query. Click the Queries tab, then click
qryMusicTracks and click OK.

3.  

Save, then close the tblMusicAlbums table.4.  

Open the tblMusicCategories table in Datasheet View and insert a Subdatasheet from the
tblMusicAlbums object.

5.  

Save, then close the tblMusicCategories table.6.  

 

4 - Exploring Relationships and Subdatasheets:
Now that the relationships have been established, isn't it time we see whether they
work?
From the Database Window, double-click the tblMusicCategories table to open it in
Datasheet View.

1.  

Type the first music category as New Age, the second will be Salsa, then Rock, and finally
Soukous.
In MS Access 2000, As you type a category, there is a new column on the table, filled with
a + sign that shows you that the current record can display child data related to that record
by the established relationship.

2.  

Then close the tblMusicCategories table.3.  

Double-click the tblMusicAlbums table object to open it in Datasheet view.4.  

For the Album Title, type Tribute and press Tab. In the Artist field, type Yanni and press
Tab.
When you get to the Music Category field, type New Age and press Tab. You receive an
error because in fact Microsoft Access considers the field as a numbered item, and indeed
it is a numbered item. For example, delete New Age, then type 1 and press Tab. It works...
This would be perfect if on one end you had just a few albums to record (then may be you
would remember the order of entry of each album or at least you would refer to the

5.  

Microsoft Access Tutorial - FunctionX

http://www.functionx.com/access/print.htm (45 of 95) [2000/11/04 09:42:32 AM]



tblMusicCategories table).
Remember, we are trying to eliminate redundancy. In other words, if you decide to get rid
of the relationship (through a divorce court ?!?) and type your values here, you might end
up with a nasty situation. The only solution is to continue and get it right. It is not difficult.
I know you are thinking, "Why not use the Lookup Wizard and configure the field?", and I
say why not fix it with a trick?"
What we mostly need is a list of the items that we are supposed to choose from, as a matter
of fact, we will use a combo box to display the appropriate list.

Delete the entry you typed for the Music Category and switch to Design View and click the
MusicCategoryID field.

6.  

In the lower part of the Design View, click the Lookup tab. It shows us that the Display
control is a Text Box.
Click the Display Control's combo box and choose Combo Box from the list. Now we can
choose between the originating table and a query to display something.

7.  

Click the Row Source, an ellipsis button appears. Click it to build a query that will be used
to select what to display in the Music Category's field.

8.  

Since you are asked to build a query in Design View, from the Show Table property sheet,
click tblMusicCategories. Click Add and click Close.

9.  

From the tblMusicCategories table, double-click MusicCategoryID, then double-click
MusicCategory to select both items.

 
Then, save and close the query. If you are asked to save, click Yes.

10.  

After you have chosen the fields, you still have to tell Microsoft Access how you want to
display them.
We will bound only one column from the tblMusicCategories table to ours, so, set the
Bound Column to 1.
From the tblMusicCategories table, we will consider using two columns, the
MusicCategoryID column to identify the originating table (remember, that column is
holding the Primary Key) and the MusicCategory column. So, set the Column Count to 2.
We don't want to display the column's title in the Combo box (we already have it in the
column heading). So, keep the Column Heads to No.
When we display the Music Category combo box, it is not important to display the Primary
Key in this example because it is an AutoNumber (set by Microsoft Access) and doesn't
mean much to us. There are situations where we might want to display it, for example
when employee numbers or banks accounts customers are used as primary keys. For this
example, we will hide the Primary Key. On the other hand, we will display the Music

11.  

Microsoft Access Tutorial - FunctionX

http://www.functionx.com/access/print.htm (46 of 95) [2000/11/04 09:42:32 AM]



Category only. To accomplish this, we will set each column's width appropriately. So, set
the Primary Key's column width to 0 and the other to a number greater than 0. In the
Column Widths field, type 0";1".
Depending on your intentions, you can control how many items the (Music Category)
combo box can display at a time when it is dropped down; the suggested number is 8, let's
keep it there. Keep the List Rows to 8.
When the combo box drops down, sometimes you have narrow items, sometimes, you have
wide ones. You can control how much space (width) is necessary by setting the List Width
accordingly. For this example, set the List Width to 1.
Finally, you can impose a number of items from the list to the data entry personnel or allow
her to add items by typing new ones that are not in the list. This time, you should really
decide how you are planning to do this. Here is an example. If you impose a list to the user,
she cannot make a mistake in typing since she will only choose from the list. But if you
allow a new entry in box, she might type Neo Age by mistake when New Age is already in
the list; the database will allow it and your database will have two entries for Yanni and for
the same album. I can hear you saying, "So what, that's not a big deal". now consider that
this is a bank and at the end of the month, you find out that a certain customer has three
bank accounts in your bank and nobody knows where those accounts are coming from...
For this exercise, set the Limit To List to Yes.

Then save the tblMusicAlbums table and switch back to Datasheet View.12.  

To continue our entry, type n in the Category for Yanni and press TAB. Microsoft Access
will complete the Category entry with New Age. For the label, type Virgin. The year will
be 1997. In the Format field, type CD. For the number of tracks, type 11. For the Notes,
type Live Concert.

13.  

Now build a combo box field for the Album Title field in the tblMusicTracks table.14.  

5 - Junction Tables And Relationships:
We know that the main idea behind the relationships is to avoid redundancy of data
by allowing some tables to provide data to others. Another kind of relationship, very
important, is by creating a middle table whose purpose is to join other tables;
actually, you don't type any data in it, you use different columns to choose existing
data from other tables.

By now you have realized that wizards are very useful when a job seems easy, for
example, they can help you create a relationship very quick and without any worries.
To implement our new relationship, we will use the wizard to create a junction table.

Open the Videos3 database, and from the Database Window, double-click Create Table In
Design View.

1.  

In the first field, type VideoJunctionID. Set it as the Primary Key formatted in
AutoNumber and set its caption as Video Jct ID.

2.  

Save the table as tblVideoJunctions.3.  

In the second field, type VideoID, press Tab, type L and press F6.
This will call the Lookup Wizard.

4.  

In the first page of the Lookup Wizard, accept the first radio button and click Enter.5.  

In the second page, choose tblVideos and press Enter.6.  

In the third page, double-click VideoTitle and click Next.7.  

In the fourth page, accept to Hide Key Column and click Next.8.  

In the fifth page, label the column caption as Video Title and click Finish.9.  

Accept to save the table.
You should be in the lower part of the Design View because you pressed F6 before starting
the wizard. Delete the default value of 0.

10.  

For the third field of the table, type ActorID, press Tab, type L and press F6.11.  

Accept the first radio button of the wizard and click Enter.12.  
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Choose tblActors and click Next.13.  

Click the >> button, and click Next.14.  

In the fourth page, accept to Hide Key Column and click Next.15.  

For the label the column, type Actor/Actress, and click Finish.16.  

Accept to save the table.
Delete the default value of 0.

17.  

Switch to Datasheet View.18.  

In the Video Title, type be, press Tab. In the Actors/Actress field, type ed and press Tab
twice.

19.  

For the second Video Title, type be, press Tab. In the Actors/Actress field, type he and
press Tab twice.

20.  

Now you can join/connect different different actors to the movies the starred in. When you
finish, close the tblVideoJunction table and close the Videos3 database.

21.  

Save and close everything.●   

 

Help In Microsoft Access:
Click the Office Assistant and type: What is a relationship?1.  

Click Create Or Modify Relationships.2.  

Click Learn About Relationships In A Database.3.  

Designing Forms
1 - Introduction:

If we agree that tables are where you will spend time
designing the functionality of your database, forms are
where you will spend a lot of time, especially in the
beginning, to design the look of your database. As a small
note, keep in mind that many companies or bosses will not
just pay you for being able to create a database, how it
looks sometimes count tremendously.

2 - Creating A Form In Design View:
Microsoft Access comes equipped with a lot of features to suit your tastes, but it is
up to you to be aesthetically creative.
Open the Music Collection3 database.1.  

From the main menu, click Insert -> Form.2.  

In the New Form dialog, click Design View.
In the combo box, choose the tblMusicAlbums table, and click OK.
You get a raw form, a toolbox, and the table's field list.

3.  

Microsoft Access Tutorial - FunctionX

http://www.functionx.com/access/print.htm (48 of 95) [2000/11/04 09:42:32 AM]

http://www.functionx.com/fpdb/Music%20Collection2.mdb


To perform your design, a form has two rulers, one horizontal on the top of the form, one
vertical on the left, to help you be more precise with dimensions. Then you have a toolbox
equipped with buttons, edit boxes and other items you can use to give a lot of flexibility to
your application. Usually, you will have the toolbar whenever you are working in the
Design View. You also have the originating table, the field list, on your screen in case you
want to add an item that you didn't include in the beginning. When you don't need any or
both of these two items, you can hide them by clicking their buttons on the toolbar.

There are different ways you can retrieve an item from the list and place it on your form.
For example, you can drag one from the list and place it on the form. You can also
double-click on the title bar of the field list to select all items, then drag all of them to the
list.

Double-click on the field list's title bar to select all items from the list, then click in the
blue list and drag everything to the form.
At first, you might get something that looks messed up, but that's why you will design and
customize it.

4.  

Save the form as frmAlbums, then close it.5.  

Now open the frmAlbums1 form in Design View.6.  

To manipulate an item on the form, you click on it to select it. To select more that
one item, you can click the first one, then you hold down the Shift key and click the
other different items that you need. If all the items you want to select are on a certain
portion or angle of your form, you can drag/draw an empty rectangle that covers all
the items that you want to select. If the items that you want to select are aligned, you
place your mouse in the ruler that corresponds to the alignment until it becomes an
arrow, then you click.

The main area you work on is called the Details area. But a form can be divided in
different sections or areas. You can have a Header section where you would write a
title or anything you want to keep on top of your form. In the same way, you can
have a Footer section to display some data, for example the date and/or time.

In Design View, a form has a small square on the intersection of both rulers in the

top left area . This area (normally, it's a button) can be used to access some of
the properties of a form.
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3 - Form Design:
In Design View click any of the edit boxes.
If you place your mouse on different parts of the selected edit box, it gets different shapes.
The open hand means you can move the whole item including its label and its edit box.
The closed fist with a pointing finger means you will move only the item where the mouse
is positioned. The double arrow means you can enlarge or shrink the item where the mouse
is pointing.
To change the forms size, that is to enlarge or shrink it, you place your mouse on one of
the borders until the pointing mouse arrow changes to a solid black line with double
arrows, then you can increase (enlarge the table) or decrease (shrink) the size of the table.

1.  

Then place you mouse inside the horizontal ruler in dimension 1 1/2 until it becomes a
down arrow, then click. That selects all items on the form.
Place your mouse on one of the items until you see an open hand, then drag everything to
the right until both rulers show a 1/4 dimension.

 
Click anywhere in an empty area of the form to deselect the items.

2.  

Design your form and move items, play with the mouse for a while until you get
something that looks like this, or suit your taste.

3.  
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When you are finished, click the Form View button on the toolbar to preview your
form.
If some items don't appear in the form or you think that the window is too large for
the items on the form, on the main menu, click Window -> Size To Fit Form.
Save and close the form.

Sometimes, there might be so many items on your form that you can't keep them
aligned. The best solution in not to delete them but to move some items and
accommodate space.

   

4 - Filling Out A Form:
To fill out a form, you go through different boxes either by typing values, choosing
values available, or causing values to be calculated from other values provided. To
move from one box to another, you can click with the mouse. To move from one
box to the next, you can press the Tab key. To move from one record to another, you
use the Navigation buttons at the bottom of the form, these buttons and their edit box
behave as those we already saw in the tables designs.

Open the frmAlbums3 form. It might look like the following:

 

1.  
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Press Tab to move through different boxes.

Click the New Record button on the form to enter a new record.
Use the Tab key to move from one box to another.
For the new Album Title, type Tekit Izi; the Artist is Kassav', the  Category is Zouk; it was
released in 1992; the label is Sony; the CD album has 10 tracks; you can leave the
Comments empty.

2.  

While you are moving from one box to another using the Tab key, if the cursor doesn't
land to the next box, then you should adjust the order of navigation. You control that from
the Tab Order dialog box.
Switch to the Design View. Then click View -> Tab Order (you could also right-click in
the design view and make your choice.

 

3.  

As we have learned how to move items in a table, move the items appropriately until you
get the order you want. Then save the form.

4.  

When you have finished, close the form and the database.5.  

5 - Improving Forms Looks
A form is supposed to look good because some people will spent a great of time
looking at your forms. Although what is going on behind a form is very important,
people might not pay enough  attention to your database if your forms are boring in
design, take too much space on the screen, don't use enough space on the screen,
hide and disappear some time to time.

Different forms are meant to accomplish different purposes. The process you use to
create a form is the same, the end result is different. Some dialogs are used as a
splash screen while some others are used as intermediary dialogs, some others serve
as the basis to register customers. We will keep these in mind as we go along.
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6 - A Form In Simple Form:
Some forms are meant to be small, they don't hold too much (unnecessary) data.

Start Microsoft Access and open the Videos4 database.1.  

Open the tblActors table to view, then close it. On the main toolbar click the AutoForm
button. That creates  a quick and simple form for you. 

2.  

Click the Design View button to open the new form in Design View. Enlarge the form by
dragging the lower right border of the form.

3.  

While you are building/designing your form, change to Form View some time to time to
preview its looks. Then come back to Design View.

4.  

Click inside the horizontal ruler at dimension 2 and drag left until the black box can cover
all items on the form, then release the mouse.

5.  

Place your mouse on one of the selected items and drag down right until the left border is
at 1/4 from the form's left border (as seen on the horizontal ruler; and the top corner is at
1/2 from the form's top border.

6.  

Enlarge the forms main right border to 3 5/8. Enlarge the form's bottom border at 1 3/8 on
the vertical ruler.

7.  

Click inside the horizontal ruler at 1/2, that should select both labels.8.  

Change the font to Times New Roman, size = 12, Bold, color = Blue (6th column, 2nd
row).

9.  

On the main menu, click Format -> Size -> To Fit.10.  

Inside the horizontal ruler, click on 2, then change the font color to Blue.11.  

Right-click on an empty area inside the form, choose Fill/Back Color -> Choose Light
Blue (6th column, 5th row).

12.  

Make sure you have the toolbox, otherwise, right-click inside the form and choose and
choose Toolbox. On the toolbox, click the Rectangle. Then draw a rectangle that goes from
1/4 top ruler and 1/8 left ruler to 3 3/8 top ruler and 3/8 left ruler.

13.  

With the rectangle on the form still selected, on the Formatting toolbar, click the Special
Effect button and choose Sunken.

14.  

On the toolbox, click the label control and click at 3/8 horizontal and 1/8 veritcal (don't
worry, you will adjust it later). Then type Actors - Actresses Registration, and press Enter.

15.  

With the new label still selected, change the font to a Serif one (I chose Baskerville Old
Face, I think I got it from Corel Draw 6 package; just choose a good but not too wide Serif

16.  
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font), size 14 (I chose 16), Bold, set the color to Light Green (4th column, 5th row). On the
main menu, click Format -> Size -> To Fit.

With the new label still selected, press Ctrl + C to copy it. Then press Ctrl + V to paste it.17.  

Still don't touch any of both labels. Set the Color to Navy or Dark Blue (7th column, 1st
row).

18.  

Now, adjust the positions of both labels so that the lighter of both will create a shadow-like
effect to the other. If the lighter label seems to be on top of the other, play with Format ->
Bring To Front, and Format -> Bring To  Back.

19.  

Finally, click the rectangle on the toolbox and draw a small rectangle on the bottom side of
the form. Make it look like a wide line, enlarge to be as wide as the largest item of the
form. Change its color to Green (4th column, 3rd row). Set its Line/Border width to 1 and
its Special Effect to Flat.

20.  

Switch to Form View to see the result. On the main menu, click Window -> Size To Fit
Form.

21.  

Save the form as frmActors.22.  

 

 

7 - Tabular Form:
A tabular form is use to edit data in a row when many data details on one table depend on one
particular data available on another table.

From the main menu, click Insert -> Form.1.  

In the New form dialog choose AutoForm:Tabular. Set the originating table or query as
tblVideoHunctions and click OK.

2.  
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Switch the form to Design View. The new form has a form header section, a detail section,
and a footer section.

3.  

Inside the horizontal ruler, click 1/2, that will select the Video Jct ID's ladel and text boxes.
resize both so that their right border will coincide with 1/2 on the horizontal ruler. Click
the Video Jct ID, that will put it in Edit mode. Change its caption to read Jct ID.

4.  

In the horizontal ruler, click 1 1/2 to select the Video Title label and the text box under it.
Then drag their left border to 1/16 of the left items.

5.  

In the vertical ruler, click 1/8 to select all the (top) labels. On the Formatting toolbar,
change the font to Verdana (if you don't have Verdana, choose Arial), size 10, Bold,
Underline, Center, Font/Fore Color Blue (6th column, 2nd row).

6.  

On the vertical ruler, click 1/8 corresponding to the detail section, that will select all the
text boxes. Click the Font/Fore Color button (it should still be set to Blue).

7.  

Click the Form Header bar and set the Fill/Back Color to light blue (6th column, 5th row).8.  

Click the Detail bar and click the Fill/Back Color.9.  

Save the form as frmVideoJunctions. Then close the form.10.  

 

8 - Getting Help In Microsoft Access:
Click the Office Assistant and type Form Design.1.  

Click Create A Form.2.  

Click Create a form on my own.3.  
    

Exploring And Analyzing Data
1 - Introduction:

In a database, it is very important to store valuable data, then to search and retrieve
what is important. This comes from a good organization of your tables.

2 - Finding and Replacing Data:
You can search and find data on a table easily by using the find feature in Microsoft
Access, combined with wildcards, which is helpful if your table has a lot of records.
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Start Microsoft Access and open the GHHS2 database.1.  

Open the tblStudentRegistrations table in Datasheet View.2.  

To find the student whose last name is DeGaram, on the main menu, click Edit -> Find... In
the Find What combo box, type degaram. In the Look In combo box, choose
tblStudentRegistrations. In the Match combo box, choose Whole Field. Then click the Find
Next button.

3.  

To find the student whose long name start with Andria..., in the Find What combo box, type
andria* and click Find Next.

4.  

To find a student whose name contains dou but you don't remember how to type it, in the
Find What combo box, type *dou* and click the Find Next button.

5.  

To find a student whose name sounds like the country whose Paris is the capital but might
not be written the same way, in the Find What combo box, type fran?e and click the Find
Next button.

6.  

You can also combine wildcards to do your search/finding. In the Find What combo box,
type *antan? and click the Find Next button, you will get Dr. Julia Sanatana.

  

7.  

Close the Find and Replace property sheet. 8.  

Replacing existing data is done just as easily, whether using wildcards or not.●   

On the main menu, click Edit -> Replace...1.  

In the Find What, type vittas. In the Replace combo box, type Bitha. Then click the Find
Next button to make sure that the right name will be replaced. Once you find Vittas as a
student's last name, click Replace.

2.  

Manually edit the student's e-mail address with bithaj.3.  

Click the Find tab. in the Find What combo box, type *vittas and click the Find Next
button.

4.  

Save the table.5.  

 

3 - Sorting Records:
The most basic way to organize is to sort it alphabetically.
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To organize the student's Last Names alphabetically, click any student's Last Name on the
table. Then on the main menu, click Records -> Sort -> Sort Ascending.

1.  

When you are finished viewing, click Records -> Remove Filter/Sort.2.  

Since we have male and female students, you can view a list of female students followed by
male students or vice versa by sorting by gender. Click somewhere in the gender column,
then on the toolbar, click the Sort Descending button.

3.  

When you have finished viewing, click Records -> Remove Filter/Sort on the main menu.4.  

You can find out which students live in a single parent home by sorting also.
Right-click on the column header of Single Parent? (Make sure you don't click on any field
under the column header) and choose Sort Ascending.

5.  

When you are finished viewing, click Records -> Remove Filter/Sort.6.  

 

4 - Using Selection To Filter Records:
While sorting rearranges data, filtering allows you to isolate data specifically. For
example, when you order the Single Parent? column alphabetically, you get a list of
girls first, then the boys. You can make a specific list that will include only one of
the categories. 
Click an M record under the Gender column. Then on the main toolbar,  click the Filter By

Selection button . That will give you a list of male students in the school.

1.  

When you have finished viewing, click the Remove Filter button  on the main toolbar.2.  

To get a list of the students who live outside of Maryland, right-click any MD under the
State column and choose Filter Excluding Selection.

3.  

When you have finished viewing, click the Remove Filter button on the main toolbar.4.  

To get a list of the students who live in Silver Spring, right-click in the City column, click
in the Filter For edit box, type Silver Spring and press Enter.

5.  

When you have finished viewing, click the Remove Filter button on the main toolbar. 6.  

5 - Using Wildcards To Filter Records:
The Filter By Form feature allows you to filter records by assigning appropriate
criteria. The Filter By Form is like a dialog box in the form of a datasheet where you
decide how to set the criteria.

To get a list of students who live in single parent homes, click the Filter By Form button on

the main toolbar . In the datasheet dialog, check the box under Single Parent? and
delete any criteria in the other boxes.

1.  

Then click the Apply Filter button on the main toolbar.2.  

When you have finished viewing, click the Remove Filter button on the main toolbar.3.  

To get a list of students whose parents are doctors, click the Filter by Form button. In the4.  
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box for Parent(s) Name(s), type Like "Dr*" and click the Apply Filter button.

You can also use a combination of criteria to get a more specific list. For example, to get a
list of female students who live in a single parent home, click the Filter By Form button on
the main toolbar. In the data sheet, make sure the Single Parent? box is checked. Then in
the Gender column, drop the combo box and choose "F". Click the Apply Filter button.

5.  

When you have finished viewing, click the Remove Filter button on the main toolbar.6.  

To get a list of students who either live in Silver Spring or live in Arlington, click the Filter
By Form button. In the data sheet, make sure you are working from the Look for tab

. Select Silver Spring in the City combo box. Click the Or tab, then
select Arlington from the City combo box. Click the Apply Filter button.

7.  

6 - Hiding And Unhiding A Column:
Sometimes, some columns or categories of data are not important for the time being
on a table. For example, if you want to print data in table and find that you don't need
to print every category of data on that table. Thus, you can simply hide the
appropriate column.

Right-click on the column header for the Single Parent? and click Hide Columns.1.  

To bring back a previously hidden column, on the main menu, click Format -> Unhide
Columns...

2.  

The Unhide dialog shows you, on a list, all the fields that are part of the table. Scroll down
if necessary until you see that the Single Parent field is unchecked. Click to check it and
close the dialog.

3.  

This time, you can close the table, and the database.4.  

 

Tables Looks
1 - Introduction:

Sometimes tables look boring, but it is up to you change that. You have two courses
of action here. You can work on your table looks for navigation purposes, thus
making your users life easier, in case you give them access to your tables. You can
also improve the resolution of your tables by temporarily hiding columns that you
don't need.

2 - Column Width:
You can control a field's size in different ways. If you just want the column to fit its
widest entry, you can double-click the right border of the column header.

Open the  Employees2 database and double-click the tblEmployees table to open it in
Datasheet View.

1.  

Place your mouse on the right border of the MI column until the mouse pointer becomes a
vertical line, then double-click. This resizes the column width to fit the widest entry. 

2.  
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You can also set a fixed width for a column. For example, a column that represents
people's membership number to a club usually follows a set pattern. In our Library3
database, all employee's numbers have the same width since they are meant to
enclose ten characters.

Click in the Employee # column and from the main menu, click Format -> Column Width.
The Column Width dialog box allows you to set the width.

1.  

In the Column Width edit box, type 13 and click OK
   

 
  

2.  

The last resource you have you have is to enlarge or shrink a column width manually.
Place your mouse on the  of the right border of the E-Mail Address title column until the
mouse pointer becomes a vertical line, press and hold the mouse and move it left and right
until it gets the width you want. 

 

3.  

3 - Row Height:
If you want to use more height space than set by default, you can change the row
height using the Row Height dialog box.

With the tblEmployees table still open and any of its cells has focus, from the main menu,
click Format -> Row Height.
In the Row Height edit box, type 20 and press Enter.
  

  

1.  

Close the tblEmployees table.2.  

4 - Controlling The Table's Font Properties:
You can use the Font... menu to set the font of data on a table.

The Employees2 database should still be opened. Open the tblEmployees2 table in
Datasheet View.

1.  

From the main menu, click Format -> Font...2.  

Using the Font dialog box, you can change the font displayed on the table.
Change the font face to either Verdana; if you don't have Verdana, choosse Tahoma;
otherwise choose MS Sans Serif. Set the font style to Bold, keep the font size to 10 and
change the color to Blue. Then click OK.

3.  
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When necessary, adjust and change different column widths to display their contents
accordingly.

4.  

5 - Datasheet Formatting:
The Datasheet menu allows you to control the gridlines looks on a table.

From the main menu, click Format -> Datasheet... 1.  

In the Datasheet Formatting dialog box, play with different features and see what they
produce.
For our example, set the Cell Effect to Flat, make sure the Gridlines Shown Vertical and
Horizontal check boxes are checked, set the Background to White, the Gridlines to Fuchsia,
and all the Borders and Line Style as Solid. Then click OK.

2.  

When you have finished making adjustments, close the table and the database.3.  

6 - Exercises:
The GCS database

Open the Georgetown Cleaning Services3 database..  

Open the tblCleaningOrders table in Design View.b.  

Set the Default Values of the items prices (the reason we are doing this is to make
sure the items prices get transferred from one record to the next; if you type the price
of each item in the table datasheet view or in the form, you will have to type the
price every time you have a new customer... very annoying).

c.  

1.  

Silver National Bank2.  
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Queries - Design And Exploration
1 - Introduction:

A query can benefit from your creativity. Just like a table and/or a form, a query is a
matter of planning and good design.

2 - Creating A Query In Design View:
To create a query, the first decision you make concerns the source of data.

Start Microsoft Access and open the Videos4 database.1.  

In the Database Window, click the Queries button, then double-click Create Query In
Design View.

2.  

You should receive the Show Table property sheet that allows you to specify where data for
the query will come from.

In the Show Table property sheet, click tblVideos, click the Add button and close the Show
Table property sheet.

3.  

Once you have the originating table or query as a list, you can choose which fields are
necessary for the query. If you want to use all the fields, double-click on the list's title bar,
that will select all fields. Then drag the whole group in the lower part of the query. To
select different fields from the list you can click each one and drag it to the query. To get a
group of different fields, click VideoTitle, hold the Ctrl key down, then click Director and 
click Rating. Once you have that list, drag one of the selected fields, for example Rating, to
the left column of the query.

4.  

Save the query as qryVideos.5.  

Run the query. Then switch back to Design View.6.  

To expand your query, you can add fields as you like, just drag the needed field from the
list and drop it on top of the field that will succeed to it. For example, drag the
YearReleased and drop it on top of Director. Then run the query. 

7.  

When you have finished viewing the query, switch back to Design View.8.  

You can move fields in Design View the same way you do for a table. For example, click
the small bar on top of YearReleased and release the mouse, that will select the whole
column. Then click again on the column header and drag it between Director and Rating.

9.  
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Then run the query. When you have finished viewing the query, switch back to Design
View.

10.  

You can build a query using data from different tables or queries as long as these objects
are related. You have to select fields from the table or query that you add using the Show
Table property sheet.
Click the Show Table button on the toolbar. From the Show Table property sheet,
double-click tblVideoCategories then close the Show Table property sheet.

11.  

To change the starting field in a query, drag the appropriate field to the first field in the
query. For example, drag VideoCategory from tblVideoCategories and drop it on top of
VideoTitle.

12.  

Then run the query. When you have finished viewing the query, switch back to Design
View.

13.  

Once you have selected certain tables or queries to participate in your query, their fields are
listed on different parts of the query. This allows you to choose easily which ones to add to
your query. For example, in the empty field next to Rating (on its right), click in the Field
box. A combo box appears. Click on its arrow to drop it down.

    

14.  

From the list, select tblVideos.Length.15.  

Then run the query. When you have finished viewing the query, switch back to Design
View.

16.  

Now you can run different instances of the query using the techniques we have learned to
sort and filter tables and queries.

17.  

Save and close the query. Then close the database.18.  
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3 - Hiding Fields From The Query:
Instead of showing or not showing some fields on a query, you can decide to hide a field (or some
fields) for some particular purpose.

Open the Music Collection4 database.1.  

From the Database Window, click the Queries button, then double-click Create Query In
Design View.

2.  

From the Show Table dialog, double-click tblTracks, and click the Close button.3.  

From the tblAlbums list, double-click the * button, that will select/include all fields.4.  

Switch to Datasheet View. On the main menu, click Format -> Unhide Column...5.  

In the Unhide Columns dialog, uncheck ID, Album and Notes.

  

6.  

Click Close and view the query.7.  

Save the query as qryTracks before closing it.8.  

 

2 -Text Combinations In Queries:
When combining calculated fields, you are allowed to name the new field; otherwise, Microsoft
Access will give a default name.

Open the Employees2 database.1.  

On the Database Window, click the Queries button. Then double-click Create Query In
Design View.

2.  

From the Show Table dialog, double-click tblEmployees and click Close.3.  

From the tblEmployees list, double-click EmployeeID.4.  

Press Tab to move to the next field box on the right. Press Shift + F2.5.  

Type [FirstName] & " " & [LastName] and click OK.6.  

Run the query. Since you didn't give a name to the new field, Microsoft Access called it
Exp1. Switch back to Design View.

7.  

Right-click in Exp1 and choose Zoom... Replace Exp1 with FullName and click OK.8.  

Run the query again. Now you have a specified column name. The only thing left to change
is the caption a user sees on the column header. Switch back to Design View.

9.  
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Right-click somewhere in the FullName column and choose Properties. In the General tab
of the Field Properties dialog, in the Description field, type This is the employee's full
name. This description will be seen on the Status Bar when a user clicks a name. In the
Caption field, type Employee's Name. Then close the Field Properties dialog.

10.  

Run the query.11.  

Save the query as qryEmployeesAddresses.12.  

Close the Employees2 database.13.  

Open the Georgetown Cleaning Services3 database.14.  

Open the tblCleaningOrders. Drop the Clerk combo box down to see the names of the
employees. Switch the table to Design View.

15.  

In Design View, click the EmployeeID field. In the lower part of the view, click the
Lookup tab. Right-click the Row Source field and choose Build... Delete or Replace
LastName in the LastName field with Clerk: [LastName] & ", " & [FirstName]. Sort it
Ascending. Close the query and accept to save it.

16.  

Switch the table to Datasheet View and drop the Clerk combo box. It now displays the last
name followed by the first name.

17.  

 

3 - Subform From A Query: 
The primary purpose of a subform is to display children data of a parent form. It allows you to
show data related to the main source. We have already created subform in the past. This time, we
would like the form a little friendlier and better looking. To get that, we will create a subform
from a query that is itself created from a table.

Open the Music Collection5 database.1.  

From the main menu, click Insert -> Query.2.  

From the New Query dialog, double-click Design View.3.  

From the Show Table dialog, double-click tblTracks and click Close.4.  

Click AlbumID, hold the Shift key, and click TrackLength. That will select four fields.5.  

Drag the selected group to the first column of the lower portion of the design grid.6.  

Save the query as qryTracks. Then close it.7.  

On the Standard toolbar, click the New Object arrow and choose Form.8.  

In the New Form dialog, choose Form Wizard and choose qryTracks in the lower combo
box. Then click OK.

9.  

Make sure the qryTracks is selected as the source of data. Select all fields and click Next.
Choose the Tabular layout, the Standard style and click Next. Name the form sbfTracks,
click the Modify the Form's Design radio button, and click Finish.

10.  

Right-click the Album Title's label and choose Properties. Click the All tab and set the
Visible field to No.

11.  

Click the AlbumID text box and set its Visible field to No.12.  

Decrease the widths of both the Album label and the AlbumID text box to 1/16 (or less,
they are not going to be seen).

13.  

Click the button at the intersection of both rulers to access the form's properties. In the All
tab, set the Navigation Buttons field to No.

14.  

Save the subform.15.  
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Open the frmAlbums form in Design View.16.  

On the Toolbox, make sure that the Control Wizard is pressed. Then click the
Subform/Subreport button. Click somewhere in the lower portion of the form.

17.  

On the Subform Wizard page, choose sbfTracks1 and click Next. Click Next again, and
click Finish.

18.  

Resize the subform to fit proportionately in the form.19.  

Save and close the frmAlbums form.20.  

 

 

Getting Help In Microsoft Access:
Click the Office Assistant and type Query.1.  

Click Queries: What they are and how they work.2.  

Click the graphics link.3.  

 

Forms Design Properties

1 - Introduction:
Now is the time to explore some of Microsoft Access components properties. Tables,
Forms, Reports and Pages properties are very rich and once you know how to use
them, you can make your database better looking and more functional.

  

2 - Form Design:
We have already seen that you can control a table's looks. This is not just done for
pure fantasies, sometimes it can be very useful; for example if you decide to embed a
table in a good looking form, a feature we call a subform, it is better to make sure the
table doesn't appear boring.

Open the Music Collection6 database.1.  

Double-click the tblAlbums table to open it Datasheet view.2.  

Right-click on the Album ID column header and choose Column Width...3.  

Type 4 and click OK.4.  

On the main menu, click Format -> Datasheet... (In MS Access 97, click Format -> Cells...)5.  

In the Datasheet Formatting (Cells Effects) dialog, click the Sunken Cell Effects and click
OK.

6.  

On the main menu, click Format -> Font.7.  

In the Font dialog, change the font to Verdana, or Helvetica, or Tahoma (I am sure you
have one those fonts, otherwise, choose any Sans Serif font, like Arial...). Set the font color
to Blue (Regular, 10) and click OK.

8.  
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Save and close the tblAlbums table.9.  

Double-click the tblTracks table to open it Datasheet View.10.  

On the main menu, click Format -> Unhide Columns...11.  

In the Unhide Columns dialog, in the Columns list, click the Track ID, the Album Title,
and the Notes check boxes to remove them. Then close the Unhide Columns dialog.

 

12.  

On the main menu, click Format -> Datasheet ... (Format -> Cells...)13.  

Set the Cell Effects to Sunken and click OK.14.  

On the main menu, click Format -> Font...15.  

Set the font to Verdana, Blue and click OK.16.  

Right-click the Track Title column header and choose Column Width. Set the width to 36
and click OK.

17.  

Save and close the tblTracks table.18.  

3 - Design Considerations:
Form properties range from the background to the header and footer sections of the
form. You can use a combination of fonts, font colors, and other font styles to
improve the looks of those controls and sections.

Click the tblAlbums table to highlight it.1.  

On the Standard toolbar, click the New Object: AutoForm button.2.  

Switch to Design View.3.  

Select everything in the form and move it to 1/4 horizontal and 1/8 vertical rulers.4.  

Enlarge the Album ID label so that its right border aligns with 1.5.  

Select all the labels, only the labels (and without the subform), then right-click any of the
highlighted labels and choose Size -> To Widest.

6.  

Select the AlbumID text box and move it to 1 1/8 horizontal ruler.7.  

Select all the text boxes (without the subform).8.  

Right-click any of the highlighted text boxes, choose Align -> Left.9.  

Resize the AlbumID text box so that its right border aligns with 1 7/8 horizontal.10.  

Press and hold the Shift key, then click the Format and Label text boxes to select them,11.  
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then release.

Right-click any of the highlighted text boxes, choose Size -> To Narrowest.12.  

Click the # Of Tracks label to give it focus. Click it again to edit. Make it read Tracks.13.  

Resize the Year and Tracks labels and text boxes, then move them right of the Format and
Label text boxes.

14.  

Move the Notes label and text box right to the other items.15.  

(Skip this if you are using MS Access 97) Move the subform up under the other items.16.  

Switch to Form View. On the main menu, click Window -> Size To Fit Form.17.  

Save your form as frmAlbums1.18.  

4 - The Form Header Properties:
The first thing you realize about about a form is that it is made of sections: the header, the detail,
and the footer sections. They are now necessary different as far as the design is concerned, it is
their functionality or roles that set them apart.

Open the frmAlbums2 in Design View.1.  

On the main menu, click View -> Form Header/Footer. That creates three sections on your
form.

2.  

On the toolbox, click the Label control.3.  

Click in the Header section and type Music Collection - Albums and press Enter.4.  

We have used the Formatting toolbar in the past to format font. Now let's explore the form
and controls properties.
Right-click on the new/highlighted label and choose Properties.

5.  

Click the Format tab.6.  

Make sure that the Caption displays Music Collection - Albums. Set the Left property to
0.5 and the Top to 0.0833.

7.  

Click the Fore Color box. An ellipsis/build button appears, click it to access the color
dialog.
In the Color dialog, click the Define custom Color >> button. Set the color to Red=0,
Green=0, Blue=160, and click OK.

8.  

For the Font Name, choose Garamond, if you don't have Garamond, choose Times New
Roman, otherwise choose Georgia (or any Serif font available).

9.  

Set the Font Size to 20, and the Font Weight to Bold.10.  

On the form, right-click the Music Collection - Albums and choose Size -> To Fit.11.  

Click the Form Header bar, it becomes black/highlighted.12.  

In the Properties dialog, change the Background color to Red=169, Green=211, and
Blue=211.

13.  

In the Special Effect, choose Raised.14.  

Save your form, then switch to Form View. When you have finished viewing the form,
switch back to Design View.

15.  

 

5 - Control Properties:
You can control properties for one control as we saw with the title, you can also control many
items properties at once, as long as the items share some characteristics.
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Click inside the vertical ruler at dimension 1/8 and drag down to 1 1/5, that will select all
items in the Detail section except the subform.

1.  

In the Properties dialog, set the Fore Color to Red=0, Green=0, Blue=255.2.  

Holding the Shift key, select all the labels. On the Formatting toolbar, click the Bold
button.

3.  

The AlbumID text box is an AutoNumber set incrementally and automatically by the
database, but sometimes it receives focus even though you can't type any value in it. So, we
will make sure that it never receives focus.
Click the AlbumID text box. In the Properties dialog, in the Format tab, set its Special
Effect to Chiseled, its Font Weight to Bold, and its Text Align to Right.

4.  

Click the Data tab. Set the Enabled to No and the Locked to Yes.5.  

Click the ArtistID box. On the Properties dialog, click the Other tab. In the Status Bar Text
box, type Artist Name. In the Control Tip Text box, type Choose an Artist from the Combo
Box.

6.  

Click the Detail bar. On the Properties dialog, change the Back Color to Red=153,
Green=204, Blue=255.

7.  

Close the Properties dialog.8.  

Resize the Form Footer bar so that it is only two dotted lines down, also set its Special
Effect raised.

9.  

Switch to Form View. On the main menu, click Window -> Size To Fit Form.10.  

Save your form.11.  
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6 - Form Properties:
At this time, your form's title still displays something that makes it look like a table. By now you
might wonder whether Microsoft Access offers the ability to create a simple dialog or only an
SDI (Single Document Interface), which means the option of minimizing or maximizing the
window. You make those decisions by setting specific properties for the form.

Since you should still have the frmAlbums2 form displaying, switch to Design View.1.  

Double-click the button at the intersection of both rulers  to access general properties
for the form.

2.  

On the Properties, click the All tab.3.  

Change the Caption to Music Collection - Albums.4.  

Set its Min Max Buttons to Min Enabled.5.  

Save and close the form.6.  

On the main menu, click Insert -> Form.7.  

In the New Form dialog, choose AutoForm: Columnar; in the combo box, choose tblArtists
and click OK. Save the form as frmArtists.

8.  

Switch to Design View.9.  

Sometimes, a small form can get lost in the midst of others; the remedy is to make sure that
it always stay on top of others. You can then prevent the user from accessing any other
form as long as this small form is opened.
Access the general properties for the frmArtists form.

10.  

On the Properties dialog, click the All tab, set the Caption to read Music Collection -
Artists. Set the Scroll Bars to Neither. Set the Modal to Yes (so it will always be on top,
and as long as it is opened, the user cannot call another form or component). Set the Border
style to Dialog (so it will look like a dialog).

11.  

Since it is very important for all your forms to have a harmonized design, set the other
design properties as we did for the frmAlbums form.

12.  

When you have finished, switch to Form View. On the main menu, click Window -> Size
To Fit Form. Save your form and close it.

13.  

By the way, if you have any difficulty going back to Design View (this should be an issue
only on versions prior to 2000), close the form, highlight it in the Database Window, and
click the Design button in the Database Window.

14.  
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7 - Tabular Form:
You will quickly realize that there are situations when the tabular is more appropriate that the
columnar forms. The tabular table is usually used to join data originating from two or more
tables; no, it is not like a query. And a tabular form is built from a join table, like the Tracks form
we need to build.

In the Database Window, click the Queries object button then double-click Create Query In
Design View.

1.  

From the Show Table property sheet, double-click tblTracks and click Close.2.  

In the tblTracks list, click AlbumID, press and hold Shift, then click TrackLength. Drag
any of the highlighted items to the first field in the query.

3.  

Save the query as qryTracks and close it.4.  

On the Standard toolbar, click the New Object button arrow and choose Form. In the New
Form dialog, choose AutoForm: Tabular; in the combo box, choose qryTracks and click
OK.

5.  

Save your new form as frmTracks.6.  

Switch to Design View. Resize your form so it can fit easily on your screen. Remember to
coordinate the colors with the other forms.

7.  

Play with the controls and different properties until you get an acceptably professionally
good lovingly form. 

8.  
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8 - Techniques of Designing Forms:
The techniques you use to make you forms look better depend on various factors raging from the
capacities of the software, your mood and inspiration of the day, your customer's taste, etc.
Nevertheless, it doesn't hurt to experiment and found out what is available in Microsoft Access
design.

Open the Georgetown Cleaning Services4 database.1.  

On the main menu, click Insert -> Form. On the New Form dialog, accept Design View; in
the combo box, select tblCleaningOrders. Click OK. Save the form as frmCleaningOrders.
Make sure you have the Properties dialog on your screen, the Toolbox, and the Field List.

2.  

Right-click on the form in Design View and choose Form Header/Footer.3.  

Leave the form design view open. From the Database Window, open the frmCustomers1
form in Design View. In the Header section, click inside the vertical ruler and drag to cover
the title and the company address label, that will select them. Right-click on the selected
items and choose Copy. Close the frmCustomers1 form.

4.  

Right-click in the Header section of the frmCleaningOrders form and choose Paste. With
everything still selected, move the selection 1 division right.

5.  

Right-click somewhere on an empty area of the Header section, that will unselect
everything but highlight the Header bar indicating that the section is deselected. From the
Properties, set the Back Color to 9816831 with a Raised Special Effect. Give the same
color and same Special Effect to the Footer section.

6.  

Click anywhere in the Detail section. From the Properties, set the back Color to 14544639.7.  

Drag the OrderID from the Field List to the most right part of the  Header section. With the
OrderID still selected, set its Enabled field to No, its Locked field to Yes, its Special Effect
to Chiseled, its Font Weight to Bold, and its Font color to blue; also change its label's font
color to blue.

8.  

Drag EmployeeID from the Field List to the space under OrderID.9.  

Drag all the other items to the Detail section. Arrange them to your taste.10.  
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Open the frmCleaningOrders1 form in Design View.1.  

Click the Rectangle from the Toolbox and draw a rectangle that  covers all the top three text
boxes and their labels on the top Detail section. Set the rectangle's Special Effect to Raised.

2.  

Draw another rectangle that will cover all but only the cleaning items. Set its Special Effects
to Raised.

3.  

Draw one more rectangle that covers the Notes box and its label.4.  

Draw one last rectangle that will cover everything in the Detail section. Set its Back Color to
9816831 and its Special Effect to Sunken.

5.  

Using the Object combo box on the Formatting toolbar, select each of the first created
rectangle and on the main menu click Format -> Send to Back. Do it also for the largest
rectangle. If the smaller rectangles don't seem to have the right Back Color, set it to
14544639.

6.  

 

Controlling Data Output On Forms And
Reports

1 - Introduction:
One of the most important features of a database system is to avoid typing repeated
data. Another one is to give calculation processes to the software. You can use
expressions and calculated fields to ask Microsoft Access to take care of that side of
headache for you.
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2 - Text Display:
Many techniques are available to manipulate the display of text of your form or report.
You can combine portions of a name to display a full name by adding the first name,
the middle name, and the last name. The same process can be applied to display an
address.

Start Microsoft Access and open the Employees3 database.1.  

Double-click the frmEmployee form to open it.2.  

When you have finished viewing it, switch to Design View. Make sure you have the toolbox
handy.

3.  

From the Toolbox, click the Text Box and drop one just above the Notes box (I left enough
space in that area for the labels and boxes we are going to use).

4.  

Click the new label, click it again and edit it to read Full Name. After you have typed, press
Enter. While the label still has focus, press and hold Shift, then click the Work Phone label
to select them both. Right-click any of the selected labels and choose Size -> To Widest.
Format the label and the text box to appear like their respective counterpart on the form.

5.  

Right-click the Unbound text box and choose Properties. Click the All tab. Give the name
FullName to the text box. In the Control Source field, type =[FirstName] & ' ' & [MI] & ' ' &
[LastName]. Close the Properties dialog.

6.  

Switch to Form View to view the result. As you move through different records, you find out
that the form can display names  in full format. But there is a problem. If a full name has an
MI, it displays fine; but a name that doesn't have an MI displays an empty space, which is
annoying and unprofessional. To fix this, we will use the Immediate If function, called IIf.
When you have finished, switch to Design View.

7.  

Right-click the FullName text box and choose Properties. Right-click the Source Code field
and choose Zoom... Edit the content to read: =IIf(IsNull([MI]),[First Name] & ' ' &
[LastName], [FirstName] & ' ' & [MI] & ' ' & [LastName]).
In simple terms, this code means: "Hi, text box, if a person doesn't have a middle initial
name, ignore it and just display her first then last name, otherwise (if she does have a middle
initial name) display them all".

8.  

In the Tool Box, click another Text Box and drop that one on the right of the full name's.9.  

Edit the new label to read User Name. Format both items to be in harmony with the other
items on the form.

10.  

Right-click the new Unbound box and choose Properties.11.  

Name the text box UserName and press Enter. On the right of the Control Source field, click
the Build/ellipsis button.

12.  

Different companies use different naming conventions to assign user names to their
employees. Here, we will combine an employee last name plus the first letter of his first
name.
In the Expression Builder dialog, click the = button. Make sure the frmEmployees is selected
in the left list. In the middle list, double-click LastName. Click the & button. In the left list,
double-click Functions to expand its folder, then click Built-In Functions. In the middle list,
click Text. In the right list, double-click Left. In the top expression, click <<stringexpr>> to
highlight it. In the left list, click frmEmployees. In the middle list, double-click FirstName.
In the top expression, click <<n>> and type 1. Click OK.

13.  
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Back in the Text Box Properties dialog, convert the user name to lowercase by typing < in
the Format field.

1.  

Close the Properties dialog and switch to Form View to view the result. When you have
finished, switch back to Form View and get the Properties dialog.

2.  

Again, most companies use the user name as the e-mail name for an employee and append it
the company domain to give her an e-mail address in the form of
"shwartzp@functionx.com". I will use the same process here to show you how you can
append static text to an expression.
First, change the name of the text box from UserName to EMailAddress.

3.  

Right-click in the Control Source field and choose Zoom... Append the domain name to
complete an e-mail address as follow:
=[LastName] & Left([FirstName],1) & "@functionx.com".

4.  

Close the Properties and switch to Form View.5.  

 

3 - Calculated Expressions:
You can defer the traditional calculations to Microsoft Access to reduce typing mistakes. Once you
set your expressions clearly, the software will take care of the rest. You can type most expressions
manually, otherwise, the Expression Builder that we have used earlier can assist you.

Open the Videos5 database.1.  

Double-click the frmVideos form to open it.2.  

Switch to Design View.3.  

From the Toolbox, click the Text Box and click on the right of Qty to add a text box to the
form. Change the text of the label to Total. Format both the label and the text box to
harmonize with the other items on the form.

4.  

Right-click the text box and choose Properties. From the All tab, change its name to Total. In
the Control Source field, click the build button. In the Expression builder dialog, click the =
button. Make sure frmVideos is selected in the left list. In the middle list, double-click
VideoPrice. Click the * button. In the middle list, double-click Quantity. The expression
should now read
= [VideoPrice] * [Quantity]. Click OK. In the Properties dialog, set the text box Format to
currency. Close the Text Box Properties.

5.  
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Switch to Form View. After playing with the form, close it and close the Videos5 database.6.  

4 - Subforms:
A subform is a child of a form that allows you to instantaneously see or access data related to the
parent table. You can create a subform along with its parent table using the form wizard. You can
also use of of the related table as a subform. In Microsoft Access 2000, you can also create a table
when using the New Object:AutoForm feature. Using the Silver National Bank database, we will
make sure the user can view and even process bank transactions from the subform.

Open the Silver National Bank3 database.1.  

Click the Forms object or tab. Click the New button. Choose Design View and base the form
tblTransactions.

2.  

Right-click on the form and choose Form Header/Footer. In the Header section, place 6
labels as: 
#, Date, Type, Deposit, W/D Amt, Charge.

3.  

Drag TransactionNumber, TransactionDate, TransactionTypeID, DepositAmount,
WithdrawalAmount, ServiceCharge to the Detail section. Every time you drop a text box,
delete its label, place the text box to the very top under its corresponding header label.

4.  

Save the form as sbfAccounts.5.  

Access the subform's Properties. Set the Navigation Buttons field to No.6.  

To perform some calculations about an account's transactions, we need to regularly update a
customer's routine transactions: deposits, withdrawals, service charges, etc. Click the Text
Box on the Toolbox, click to the left of the Footer section, delete the label of the new Text
Box, resize the Text Box to roughly 2 divisions (the user will not see/use it). On the
Properties dialog, change the name of the text box to TotalDeposits, and set its Control
Source to =Sum([DepositAmount]). Drop another Text Box to the right of the TotalDeposits.
Delete its label, shrink or narrow it, change its name to TotalWithdrawals, and its Control
Source to =Sum([WithdrawalAmount]). Add one more Text Box to the right of the existing
text boxes in the Footer section. Delete its label and shrink it, change its name to
TotalServiceCharges, and set its Control Source to =Sum([ServiceCharge]).

7.  

Add one last Text Box on the right of the Footer section. Change the name of its label to
lblBalance and the Caption of its label to Balance:. Change the name of the Text Box to
Balance, and its Control source to:
=nz([TotalDeposits])-nz([TotalWithdrawals])-nz([TotalServiceCharges]) 

8.  

Select the first three text boxes (TotalDeposits, TotalWithdrawals, and
TotalServiceCharges). On the Properties dialog, set their Visible field to No. Select all the
text boxes in the Footer section and set their Format to Currency.

9.  

Before leaving, drag AccountID from the Field List to the Header section of the form (you
can drop it anywhere) and set its Visible field to No. Save and close the subform.

10.  

In Design View, create a form based on the tblAccounts. Save the form as frmAccounts.11.  
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Open the frmAccounts2 form in Design View. On the Toolbox, click the Page Break control
and click in the Detail section far left but right on 2 1/4.

12.  

Make sure the Control Wizard on the Toolbox is pressed. On the Toolbox, click the
Subform/Subreport control. Click on the form under the page break. In the first page of the
Subform/Subreport Wizard, click the Forms combo box and choose sbfAccounts1. Click
Next, Next, and Finish. Switch to Form View.

13.  

On the main menu, click Window -> Size to Fit Form. Close the form.14.  

Open the frmAccounts3 form.15.  

Click Control Wizard button on the Toolbox to deselect it. On the form, scroll down
completely to see the Footer section.

16.  

On the Toolbox, click Command Button. Click under the footer bar at 1 inch of the
horizontal ruler. On the Properties dialog, change the button's name to DetailsBtn and its
Caption to &Details. Drop another button on the right of the first button, change its name to
TransactionsBtn and its Caption to &Transactions.

17.  

Right-click the Details button and choose Build Event... In the Choose Builder dialog, click
Code Builder and click OK. Implement the procedure as follows:

Private Sub DetailBtn_Click()
    Me.GoToPage 1
End Sub
  

18.  

In Microsoft Access, right-click the other button, choose Build Event... and double-click
Code Builder. Implement the procedure as follows:

Private Sub TransactionsBtn_Click()
    Me.GoToPage 2
End Sub
  

19.  

Close Visual Basic. Switch the form to Form View. If necessary, on the main menu, click
Window -> Size to Fit Form. Click the buttons in the footer section and make sure they allow
you to access the top and bottom section of the form. Save the form.

20.  

Close the Silver National Bank3 database.21.  
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5 - Multiple Calculations on a Form:
Sometimes the tricky thing about calculations is to remember all the elements involved to produce
the desired or right result. That's what happens when you dealing with restaurant, dry cleaning
stores, etc. The calculation by itself might be a big deal and usually you don't need to get Visual
Basic involved.

Open the Georgetown Cleaning Services5 database.1.  

Open the frmCleaningOrders form in Design View. Set the DepositDate's Default Value to
=Date(). That will display the current date for the user on the form. Set the Default Value of
the RetrieveDate to =[DepositDate]+2 (this cleaning store takes two days to clean clothes).
That will automatically display the retrieve date but still give the user the option of changing
the retrieve date.

2.  

On the Toolbox, click the Text Box and click right to the PantsPrice text box. Delete the
label of the new text box. On the Properties dialog, change the name of the new text box to
ttlPantsPrice. Set its Control Source to =Pants*PantsPrice. Set its Format to Currency, and its
font color to brown.

3.  

Repeat the same technique to every one of the items on the form.4.  

Open the frmCleaningOrders1 form. Switch the form to Design View.5.  

From the Toolbox, click the Text Box and click in the Footer section. Change the label's
name to lblTotal and its Caption to Total:. Change the Text Box's name to Total. Set its
Control Source to:
=nz([ttlPantsPrice])+nz([ttlMenSuits2PiecePrice])
+nz([ttlMenSuits3PiecePrice])+nz([ttlSweaterPrice])
+nz([ttlShirtRegularPrice])+nz([ttlShirtSilkPrice]) +nz([ttlShirtWoolPrice])+nz([ttlTiePrice])
+nz([ttlWomenSuitPrice])+nz([ttlDressesPrice])
+nz([ttlSkirtBeltPrice])+nz([ttlSkirtHookPrice]) +nz([ttlCoatPrice])+nz([ttlJacketPrice])
+nz([ttlBlousePrice])+nz([ttlBeltPrice])

6.  

Switch the form to Form View. The Total box should now work and display the price the
customer owes for the cleaning.

7.  
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Help In Microsoft Access:
Click the Office Assistant and type: Expression.

Then click Create and Expression.

 

Creating And Using Advanced Queries
1 - Introduction:
Queries are used for various purposes, retrieving data is just one of them. Their flexibility and
SQL involvement makes them the primary candidate for multiple combinations and calculations.

One of the most useful issues of using queries is to combine results of calculated fields either from
the same source or from different sources. In an accounting database, you could get employees
names, combine with their pay rate, mix with tax issues coming from another source (the
government), add their bonus... then get their full pay (some of which might require SQL
statements or VBA).

 

 

Microsoft Access Controls

Introduction:
Microsoft Windows family of operating systems greatly rely on controls to enhance interaction
and usability between the application and the users. These controls come in various flavors for
different purposes. The uses of these controls depend on the application, the control's own
capabilities, and the purpose of the application.

Controls Explorations
If you have programmed in other languages, namely (Visual) C++, you are probably used to
property sheets. In Microsoft Access, these are significantly simplified (in Microsoft Visual C++,
property sheets and tab controls are really different and their programming is not related).

To explore different implementations of the tab controls, we will go step by step and study their
various uses.

To make sure you understand how what we are about to do works, I would like you to
create the database along with me. Start Microsoft Access and create a Blank database
called Pierrot's Carry Out.

1.  

From the Database Window, use the Table Wizard to create a table including the following
fields: (from the Employees sample table) EmployeeID, DateHired, EmployeeNumber,

2.  
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Title, FirstName, LastName, Address, City, State, PostalCode, Country, HomePhone, (from
the Mailing List sample) E-MailAddress, WorkPhone, Extension, Salary, (from the
Contacts sample)MaritalStatus, EmrgcyContactName, EmrgcyContactPhone, Notes. Save
the table as tblEmployees.

Set the Input Mask of EmployeeNumber to 00\-000\-0;0;_. Access the Lookup Wizard for
the Title and choose to Type the Values that you want; these values are Ms., Mr., and Mrs.

3.  

In table Design View, create another table called tblCustomers with the following fields:
CustomerID(Primary Key. AutoNumber), Customer Name, CustomerPhone (Input Mask =
!\(999") "000\-0000), and Notes(Data Type: Memo).

4.  

The Tab control:
Now that you know how the tables in this database are created, open the Annie's Carry Out
database.

1.  

From the Database Window, choose to create a form in Design View based on the
tblEmployees table.

2.  

From the Toolbox, click the Tab Control and click on 1/8 and 1/8 on the form. Access the
Properties for the tab control (here is one of the ways you can it: first make sure you have
the Properties dialog on your screen, then on the Standard toolbar, from the Object combo
box, choose the TabCtl0 object). Set the control's Tab Fixed Width to 1.98 (it might change
to another value like 1.9799, which is fine).

3.  

Access the Properties for the first page. Change its name to pgPersonalInformation and its
Caption to Personal Information. Change the name of the second page to
pgEmployeeDetails and its Caption to Employee Details.

4.  

From the Field List, drag and drop, in the first page, EmployeeID, Title, FirstName,
LastName, Address, City, State, ZIPCode, Country, HomePhone, and EMailAddress.

  

5.  

In the second page, drop DateHired, EmployeeNumber, WorkPhone, Extension, Salary,
MaritalStatus, EmrgcyContactName, EmrgcyContactPhone, and Notes. Save the form as
frmEmployees.

6.  
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Reports Design And Improvements
 

1 - Introduction:
Many people will probably spend more time looking at, or working from, your reports. That's why
you should spend a great deal of time designing them and configuring their functionality.

Although reports  appear to represent the printed sheet of paper that will display some of the
effectiveness of your database, they are very valuable because it is from here you will print peoples
time sheets, business receipts, company brochures, customers mailing labels, etc.

Some reports are quite easy to design as their minimum purpose doesn't require too much behind
the scenes functionality. Some other reports can involve (a lot of, or some) coding, where you have
to conditionality print some details concerning particular issues. As we go little by little, we will get
to more complicated reports, like designing and printing paychecks that depend on many factors
(regular time, overtime, vacation hours, bonus...).

 

2 - A Simple List:
In its simplest form, a report can just consist of names of members of a club, students in a class
room, or your friends.

Open the Music Collection7 database.1.  

On the Standard toolbar, click the New Object arrow and choose Report.2.  

In the New Report dialog, choose Design View and specify the source data as tblArtists.
Then click OK.

3.  

Right-click anywhere on the empty report and choose Report Header/Footer.4.  

On the Toolbox, click the Label, then click under the Report Header bar. Type Music
Collection - Artists Names and press Enter.

5.  

From the Formatting toolbar, change the label's font to Garamond, size=20, Bold, and color
= Green. Right-click on the label and choose Size -> To Fit.

6.  

On the toolbar, double-click the Label and click on the left side under the Page Header bar.
Type Nbr: and press Enter. Click on the right of the Nbr label to add another label, type
Artist Name and press Enter. Click the label on the Toolbox to give it back.

7.  

Select both labels (you can click inside the vertical ruler just left of the Nbr label). On the
Formatting toolbar, change the font to Garamond, Size 14, Bold, color = Brown (2nd
column, 1st row). While both labels still have focus, right-click any of them and choose Size
To Fit.

8.  

You should have the tblArtists list on the screen. Drag the ArtistID from the list to the left
side under the Detail bar. Delete its label. Resize it to be the same width as the Nbr label.
Drag the ArtistName from the list to somewhere in the Detail section. Delete its label. Move
the ArtistName text box under the Artist Name label and to the right of the ArtistID text box.
Enlarge the ArtistName text box so that it would fit/stretch from dimension 1 to 4 of the
horizontal toolbar.

9.  

Select both text boxes. Change their font to Verdana, Size=10, color = Blue.10.  

Shorten the Detail section so that it would just fit the height of the text boxes.11.  

Save the report as rptArtistsNames.12.  

Preview the report and close it.13.  
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3 - Report Design:
The techniques you use to design a form are the same you apply when embellishing your report.
The difference, which is what you will always keep in mind is that while the former is used a the
interactive screen interface serving the users, the latter will constitute the printed sheet.

The same toolbox is used to add the labels, text boxes, rectangles, lines, etc.

From the Database Window, click the Reports object button. Then click the New button.1.  

From the New Report dialog, choose Design View. In the combo box, specify tblAlbums as
the source of data. Click OK.

2.  

You need the following four items on your screen. If you don't have them, you know what to
do to get them. They are the Report1 empty report, the tblAlbums Field List, the Toolbox,
and the Report Properties dialog.

3.  

Right-click somewhere on an empty area of the Report1 and choose Report Header/Footer.
Now we have  a foundation.

4.  

From the Toolbox, click the Label, then click somewhere under the Report Header bar. Type
Music Collection - Albums and press Enter. Using the Formatting toolbar, change the Font
to Garamond, side=20, Bold, color=Green. Right-click on the new label and choose Size To
Fit.

5.  

From the Toolbox, click the Rectangle, then draw a rectangle that covers the title label
completely. In the Rectangle Properties dialog, specify good characteristics:
  

  

6.  

From the Toolbox, click the Line, then draw a line one dot from under the Page Header bar
and one dot from the vertical ruler; extend the line width to dimension 3 3/4. From the Line
Properties, change the Border Color to 255 and the Border Style to 3 pt.

7.  

Drag the AlbumID from the tblAlbums list to the Page Header section under the horizontal
bar.

8.  

Change the Caption of the AlbumID label to Album Number.9.  

Select both the label and the text box (you can click inside the vertical ruler to the left of the
label. Change their font to Garamond, size=14, Bold, color Brown. While both items are still
selected, right-click one of them and choose Size To Fit. 

10.  

Click somewhere else to deselect. Make sure the text box doesn't cover the label. If
necessary, move the text box to the right. Enlarge the AlbumID text box.

11.  

Right-click the line you just drew and choose Copy. Press Ctrl + V. Both lines are present,
one on top of the other. Drag one them under the label and the text box. Adjust both lines so

12.  
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that the Page Header section will look harmonized. 

On the Field List, click ArtistID. Hold Shift and click NumberOfTracks. Drag the whole
selection under the Detail bar.

13.  

Select all items in the Detail section. Change their font to Verdana, size=10, and color Blue.
Enlarge the ArtistID text box to accomodate long names.

14.  

Set the YearReleased and the NumberOfTracks text boxes alignments to Left (because they
are right aligned, since they are numbers.

15.  

Drag the Notes to the right of the selection. Change the Notes text box's font style to Italic,
change its font to Verdana, size=8, and color Blue. Select the Notes label and change its font
to Verdana, size=10, and color Blue .

16.  

Save the report as rptAlbums and close it. If you want, you can preview it, but there is a
chance you would wonder why we had put the AlbumIDs in the Page Header section, which
might make it not look very good to you. That's because this form will be used it the next
exercise. On your own, you could put the AlbumIDs label and text box in the Detail section.
In the next section, you will be using another report...
 

17.  

  

 

4 - Subreports:
Just as you are already familiar with subform, you can also create a subreport to embed in a parent
form. you could get an employee's yearly vacations and bonuses in one query/report, then
embedded them in his quarter or annual report.

It is usually better to create the subreport from a query. That gives you more flexibility and control
over what to display and when.

a/ Creating A Query As The Data Source:

As we are still in the Music Collection 6 database, in the Database Window, click the
Queries button. Then click the New button on the Database Window's toolbar.

1.  

In the New Query dialog, choose Simple Query Wizard and click OK.2.  

In the Tables/Queries combo box, choose Table:tblTracks.3.  
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From the Available Fields, double-click the following fields: AlbumID, TrackNumber,
TrackTitle, and TrackLength. Click Next twice.

4.  

Name the query sqyTracks. Click Finish.5.  

Close the sqyTracks query.6.  

b/ Creating the Subreport:

From the Database Window, click the Reports button. Then click the New button on the
toolbar.

1.  

In the New Report dialog, choose Report Wizard. In the combo box, choose sqyTracks. Click
OK.

2.  

Select all fields and click Next three times (accepting the defaults).3.  

For the report layout, choose Tabular and click Next twice.4.  

For the title of the report, type Album's Tracks.
Click the Modify The Report's Design. Click Finish.

5.  

In the Page Header section, right-click the Album Title label and choose Properties. In the
All tab, set its Visible field to No. In the Detail section, click the AlbumID. Set its Visible
field to No.

6.  

Change the Album's Tracks label's font to Garamond, size 16, Bold, color Brown.
Right-click on the label and choose Size To Fit.

7.  

Since the Album Title label and the AlbumID text box will not be seen, shrink them to 1/16
to the left. Move the other items to the left.

8.  

Delete everything in the Page Footer section.9.  

Bring the Report Footer bar completely up close to the Page Footer bar.10.  

Save and close the subreport. If its name is confusing, rename it sbrTracks.11.  

c/ Adding the Subreport to the Parent Report:

From the Database Window, open the rptAlbums1 report in Design View. If you have too
many items on the screen and they are taking too much space, close the Properties, and the
Field List, we need the Toolbox.

1.  

On the Toolbox, click the Control Wizard button to deselect/uncheck it.2.  

Click the Subform/Subreport button and click in the report under the lower red line. Click
somewhere to deselect. Click the Child label and delete it. Right-click the subreport and
choose Properties.

3.  

Give to your subreport the following properties:
 

4.  
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Preview your report and make some adjustments to improve its looks. Save your report, then
close it. 

5.  

Importing And Exporting Data
1 - Introduction:

Microsoft Access can help you import data from various other applications, whether
from the Microsoft Office suite, or from other applications

You can import a time sheet from Microsoft Excel, export data to a table in Microsoft
Word, import an address book from Microsoft Outlook, or publish your data to
Microsoft Internet Explorer through Microsoft FrontPage.

  

2 - Importing Data From Another Application:
With Microsoft Access, you can use data from another or external application into
Microsoft Access. You have the ability to import or export data; you can also link to
data that exist somewhere else. Data you import can originate from various sources,
including other database applications (Microsoft Access, DBase, Paradox, ODBC
databases), spreadsheet applications (Lotus 1-2-3, Microsoft Excel), and various
others (Microsoft Word, WordPad, Notepad, Microsoft Outlook, etc). Regardless of
the origin of data, it needs to be configured to be Microsoft Access friendly.

When you are getting prepared to import data from another source, there are a few
rules you should observe, depending on the originating document. For example, for a
text document (Microsoft Word, WordPad, Notepad, etc) you have to decide on the
delimiter that will help Microsoft Access determine the beginning and end of a field
item, a separator that will be the limit line between two fields.
You can import data into an existing table or you can create a new table from the
imported data.
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3 - Importing From Another MS Access
Database:

If you have a table in another database and you want to use that table, you can either
link to or import that external table. This is a simple process once you know where the
table is located. 

Start Microsoft Access and choose to create a Blank Database called Import - Export Data.
The database we are going to create is for demonstration purposes. It doesn't have much
functionality. But by the end, we should have learned the necessary information to
import/export data.

1.  

On the Standard toolbar, click the New Object button and choose Table.2.  

Double-click the Import Table line from the list. From the Import dialog, if necessary,
browse to the right folder, double-click the Library2 database. The Import dialog comes up.

3.  

From the Import Objects property sheet, in the Tables tab, click  tblEmployees and click OK.4.  

Right-click tblEmployees, choose Rename, press End and type 1 (now the new table should
be renamed tblEmployees1).

5.  

 

 

4 - Importing Data From Microsoft Excel
Microsoft Excel is a spreadsheet application made of columns and rows. The intersection of a
column and a row is called a cell (it looks like, and maybe better than, the Datasheet View that you
are used to). Microsoft Excel uses Worksheets to display and relate its data. Everything you type in
Microsoft Excel is stored in cells, and cells are comprised in a worksheet. Microsoft Access and
MS Excel have differences in functionality or in the way they handle the content of cells. In both
apps, you can use column headers "as is", with MS Excel calling its columns A, B, C, etc; and MS
Access calling its columns Field1, Field2, etc.

If you are planning on using data created in MS Excel into your Microsoft  Access database, you
need to configure the spreadsheet to be Microsoft Access "friendly", which is usually very easy
since these apps where created with collaboration in mind. In Microsoft Excel, it is not necessary
to specifically have column headers to identify the content of a column (since it is your
spreadsheet, you can decide that, just by looking at it and using the column headers provided by the
workbook, you could figure out what the worksheet is used for). That would make Microsoft
Access also read your worksheet as is. The suggestion is to give customized headers to the
worksheet and "let Microsoft Access know" that you have already defined the column headers.
You do that by creating a special row of data to carry the "names" of columns.

To import your data, you have the option of creating a Microsoft Access table that has the same
fields as in Microsoft Excel, the columns have to match those of Microsoft Excel. Then you can
import the worksheet into the existing, already created table. You can also import a spreadsheet "as
is", in a new table, which can sometimes be easier (but not always cute). 

If you have Microsoft Excel, start it and create a spreadsheet on Sheet1. Rename the
worksheet Employees and give it appropriate fields. You can also open the Employees.xls
workbook and see what it looks like.

1.  

In Microsoft Access, create a table called tblEmployees2 with the following fields.
  

Field Name Data Type Input Mask Caption
EmployeeNumber
(Primary Key)

Text LL\-0000\-L;0;_ Empl. #

2.  
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FirstName     First Name
MI      
LastName     Last Name

DateHired
Date/Time -
Short Date

99/99/00;0;_ Date Hired

Salary Currency    
Title      
WorkPhone   !(999) 000-0000;0;_ Work Phone

  

On the Standard toolbar, click the New Object button and choose Table.3.  

In the New Table dialog, click Import Table and click OK.4.  

In the Microsoft Access Exercises folder, click the Files of Type combo box and choose
Microsoft Excel.

5.  

Click the RcdEmployees workbook and click Import. The Import Spreadsheet Wizard starts.6.  

Make sure you select the Employees worksheet and click Next.7.  

In the following page, you let the wizard know whether you have already defined the column
headers. For this exercise, click the First Row Contains Column Headings check box and
click Next.

8.  

Then you decide whether you want to create a special cute table for the new data or you
want to store data in an existing table. For this exercise, click the combo box and choose
tblEmployees2.

9.  

Click Next and click Finish.10.  

When the importing is finished, you receive a confirmation dialog:

  

11.  

Click Ok. If something goes wrong, the wizard will let you know. Then you can fix it.12.  

 

 

5 - Importing Data In Text File Format:
You can import a text database from Notepad. This time also, the text has to be
configured to send data to Microsoft Access. First, you have make sure that your text
"says" where a field content starts and where it stops. The usual way is to include it in
double quotes (" "). Then MS Access wants you to specify a Delimiter, which is like
the line between two columns. You have the choice of using the Tab key when you
type your data, or separating fields contents with a comma, then let MS Access
"know". Finally, you end each record with a carriage return (the Enter key).

Start a text application, like Notepad and open the txtEmployees file to see what it looks
like. Then close it.

1.  

In Microsoft Access, from the main menu, click:
File -> Get External Data -> Import...
From the C:\Microsoft Access Applications folder, choose Files Of Type: Text Files. For the
File Name, choose txtEmployees.

2.  
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From the first page of the Import Text Wizard, accept that the text be Delimited and click
Next.

3.  

On the second page, set the delimiter as Comma and check the box stating: First Row
Contains Field Names, then click Next.

4.  

Accept to create a new table. Click Next.5.  

In the following dialog, you could optionally configure or reconfigure some of the fields. To
do that, you click a field, then change its Data Type and/or its Indexed characteristics. For
example, click the EmployeeNumber field. In the Indexed combo box, set its field to (Yes,
No Duplicates). Click Next.

6.  

Next, you decide on the Primary Key. You can let the wizard create one for you. We will
create our own. Click the combo box and choose EmployeeNumber. Click Next.

7.  

Finally, you are asked to give a name to the table. Name it tblEmployees3. Click Finish.8.  

Once more, you should receive a confirmation message when the table has been imported.9.  

You can open the table and see what it looks like.10.  

 

 

6 - Importing a Microsoft Outlook Address Book:
Importing a Microsoft Outlook Address Book is as smooth as what we have seen so
far. All you have to do is have the address book already created and you are ready to
roll.

On the Standard toolbar, click the New Object button and choose Table.1.  

In the New Table dialog, double-click Import Table.2.  

In the Import dialog, change the File Of Type to Outlook.3.  

A particular wizard starts. In the first page of the wizard, click the + on Personal Folders to
expand it.

4.  

Click Contacts and click Next.5.  

Accept to store data In A New Table. and click Next.6.  

Click Next, Next, Finish, and OK.7.  

 

Getting Help In Microsoft Access:
Click the Office Assistant and type Import Data.1.  

Click Import Data. Proceed.2.  

Click the Office Assistant again. Click Search.3.  

Click Data sources Microsoft Access can import or link.4.  

 

Macros
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1 - Introduction To Macros:
A Macro is a set of actions you ask Microsoft Access to perform in order to automate
some behavior in your application. A macro can be used to open a table, a form, a
report, or a Data Access Page in any view of your choice.

By default, macros don't involve any programming. So, what you need to know is
how to create them, then how to run (execute) them, and finally, how to use their
behavior in your application.

 

 

2 - The Basics Of Macros:
Macros are provided in various flavors for different purposes. The apparently most basic macro
you will use can help you display a message to the user.

Open the Music Collection5 database. In MS Access 97 click the Macros tab. In 2000, click
the Macros button.

1.  

Click the New button.2.  

Click the combo box under the Action column to view some of the macros available. Type
MsgBox (you could just type ms and press Tab). In the Comments field, type A simple
message to the user. In the message box, type: Welcome to my Music Collection database.
Enjoy!. Set the Beep field to No. Set the Type to None. The title of the message box will be
Music Collection. Save the macro as mcrMessageToUser. Close the Macros window.

3.  

Double-click the mcrMessageToUser macro to run it.4.  

Click OK to dismiss the dialog.5.  

Close the Music Collection3 database.6.  

 

 

3 - Opening And Closing Objects:
You already know that macros can be used to automate some actions in your database.
Now we are going to start executing some actions in our databases.

Open the DCMS1 database.1.  

Press F11 to access the Database Window.2.  

Click the Macros button, then click the New button on the Database Window.3.  

In the Action column, select OpenForm. In the Comment field, type Used to open the
Employees form. In the Form Name, choose Employees. Set the View field to Form and the
Window Mode to Normal. The other fields will stay empty for now. Save the macro as
mcrOpenEmployeeForm. Close the macro window.

4.  

Create another macro using the Close action. In the Comment field, type Used to close the
Employees form. Specify the Object type as Form and the Object Name as Employees.
Leave the Save field to Prompt. Save the macro as mcrCloseEmployeesForm and close the
macro window.

5.  

Double-click the mcrOpenEmployeeForm macro to execute it. It should open the Employees
form.

6.  

While the Employees form is opened, on the main menu, click View -> Design View.7.  

If you don't have the Toolbox, on the main menu, click View -> Toolbox. On the Toolbox,8.  
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make sure that the Control Wizard is pressed. 

Click the Command Button. Click on the form somewhere on the intersection of horizontal 4
and vertical 1.

9.  

In the Command Button Wizard, in the Categories click Miscellaneous. In the Actions list,
click Run Macro. Click Next. Choose the mcrCloseEmployeesForm macro. Click Next. In
the Button page, click in the Text box and replace the text with Close. Click Next. Name the
button CloseEmplyeeFormBtn. Click Finish.

10.  

 

 

4 - Page Up - Page Down:
A macro can be used to navigate up and down on a form with the click on one button.

Open the Associates1 database. The Associates are a group of people who organize to save
money in an usual way. Every week, two weeks, or month, they get together and each
member deposits a certain amount of money in the "cashier" where there is a minimum. The
money is registered and deposited in an official bank account. At a set period, which could
be at the end of the year or in the middle of the year (they decide on the period when it
would happen), the "cashier box" is broken and everyone gets what he or she has
accumulated for the period. During the year, members are allowed to borrow money for
emergency situations, and they will reimburse with a percentage. Above the minimum,
members are allowed or encouraged to deposit any amount. A variant of this system of
saving would be to "give" that money to one of the members every week, every two weeks,
or every month, in a rotation fashion, until the "circle" is complete. To participate in this
organization, one has to be a registered member first. Our Associates database helps to
register members and to keep track of all transactions involved in the organization.

1.  

Double-click the frmAccountTransactions form to open it. The top of the form shows the
transactions related to the particular account displayed. The bottom of the form would allow
the user to review information about the account owner. Notice that this form is too long to
display everything at the same time on the screen. So, we will create two macros that would
allow us to go up and down on the form (could you believe this action could be performed
with only one line of VB code?). Close the form.

2.  

In the Database Window, click the Macros button.3.  

Click the New button.4.  

In the Action column, choose GotoPage. In the Description, type View Transactions related
to this Account. In the Page Number, type 1.
  

5.  
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Save the macro as mcrAccountTransactions.6.  

On the main menu, click Insert -> Macro.7.  

In the Action column, choose GotoPage. In the Description, type View Information about
this Account's holder. In the Page Number, type 2.

8.  

Save the macro as mcrAccountInfo.9.  

Now that the actions have been defined, all you have to do now is assign them the
appropriate elements to perform. To do that, we will associate each macro to a button.
Open the frmAccountTransactions form in Design View.

10.  

Scroll down, using the vertical scroll bar. Don't resize the form.11.  

From the Toolbox, click Page Break. On the form, click at 2 7/16 of the vertical ruler just
right of the vertical ruler. If you are using MS Access 97, place the Page Break right to
dimension 3 of the vertical ruler (I didn't create these two exercises on the same day). Save
and close the form.

12.  

On the Toolbox, make sure the Control Wizards is not pressed. Scroll down until you can
see the Form Footer section.

13.  

On the Toolbox, click Command Button. Drop a button in the middle left side of the Form
Footer section.

14.  

Right-click the button and choose Properties. Click the All tab. Name the button
TransactionsBtn. In the Caption, type Transactions. In the Properties dialog, scroll down
until you can see the On Click field. Click the combo box in the On Click field and choose
mcrAccountTransactions.
  

15.  
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From the Toolbox, click the Command Button again and click right of the first button.16.  

In the Properties dialog, name that button AccountInfoBtn. The Caption will be Account
Info. The On Click event will be mcrAccountInfo.

17.  

Close the Properties dialog. Switch to Form View.18.  

Click the buttons to see how they work.19.  

Switch back to Design View. When writing this database, we had decided that we would not
allow the user to update an account's information from the frmAccountTransactions, to make
sure that the records are separate. If the user wants to update an account's data, for example
if a member has changed her address or home telephone number, we will ask the user to
"call" the registration form where data can be edited or updated. Remember, the only actions
allowed to be performed from the transactions form are the transactions.

20.  

In the frmAccountTransactions Design View, click the Command Button from the Toolbox.
Click right to the other existing buttons. On the main menu, click View -> Properties. On the
Properties dialog, name that button UpdAccountInfoBtn. Set its Caption to Update Info.
Close the Properties dialog.

21.  

Right-click the new button and choose Build Event...22.  

From the Choose Builder dialog, double-click Macro Builder. Name the macro
mcrUpdAccountInfo. In the Action column, choose OpenForm. In the Comment, type
Update current account or create a new one. In the Form Name, choose
frmMembersRegistration. Save and close the macro builder window.

23.  

Switch to Form View.24.  

Click a few records. Move to record 4, then click the Update Info button. We have a problem
here. If the user is on record 4 and wants to update info for member 4, the Update Info
button should take her to record 4, and not to the beginning of the records.

25.  

Close the form. In the Database Window, click the Macros button. Click the
mcrUpdAccountInfo macro, then click the Design button. What we want to use as a
reference is the member's account number. When the user's is on a particular record and
click the Update Info button, we want the "call" to land on the corresponding account
number in the other form. The fact is, this will be on another form (although both forms use
the same data), so the safest way to configure it is to build it.

26.  

In the Where Condition field, type [AccountNumber]. You could type the whole expression
here, but to reduce the likelyhood of making a mistake, we will use the Expression Builder.

27.  

In the Where Condition field, click the Build button. Since the [AccountNumber] is
highlighted in the Expression Builder dialog and we only want to add something to it, click
at its end; you cursor is now at the end of [AccountNumber]. Click the = sign. In the left list,
double-click the Forms folder. Double-click All Forms. Click frmAccountTransactions. In
the middle list, double-click AccountNumber. Now your expression should read:
[AccountNumber] = Forms![frmAccountTransactions]![AccountNumber] .

28.  
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Save and close the macro. The problem should be fixed now.29.  

Save the frmAccountTransactions. After playing with it, close the form. Also close the
database.

30.  

 

5 - Opening Database Components:
The most usual use of macros is to open forms and reports.

Open the Music Collection 7 database.1.  

From the Database Window, click Macros. Click New.2.  

In the Action column, select OpenForm. In the Comment field, type Open the Albums form.
In the Form Name field, choose frmEditAlbums.

3.  

Save your macro as mcrEditAlbums, then close it.4.  

On the Standard toolbar, click the New Object arrow button and choose Macro.5.  

In the Action column, select OpenReport. In the Comment field, type Preview the the
Albums report. In the Report Name field, choose rptAlbums. In the View field, choose Print
Preview.

6.  

Save your macro as mcrPreviewAlbums, then close it.7.  

Open the frmAlbumsAndTracks form in Design View.8.  

On the Toolbox, make sure the Control Wizard button is not enabled. Click the Command
Button on the Toolbox and click left in the Footer Section.

9.  

Right-click the new command button and choose Properties. Name the button
EditAlbumsBtn with a caption of Edit Albums. Set its Default to Yes. For its On Click
event, choose mcrEditAlbums.

10.  

Add another button named PreviewAlbumsBtn with a caption of Preview Albums and an On
Click event to mcrPreviewAlbums.

11.  

Add another button. Right-click that button and choose Properties. name the button
PrintArtistsBtn with the caption Print Artists Names. Click the Events tab. Click the Build
button in the On Click field. Click Macro Builder and click OK. Name the macro
mcrPrintArtistsNames and click OK.

12.  

In the Action column, select OpenReport. In the Comment field, type Preview the the Artists
Names report. In the Report Name field, choose rptArtists. In the View field, choose Print
Preview. Save the macro and close it. Resize the button to fit the caption.

13.  

 

6 - Multi-Action Macros:
Sometimes you will want the call of a macro to perform more than one action. In a simple form,
we will display a message indicating to the user what he can do when he clicks the Update Info
button.

Open the Associates1 database again.1.  

From the Database Window, click the Macros button. Click the mcrUpdAccountInfo macro,
then click the Design button.

2.  

In the 3rd line of the Action column, choose MsgBox. In the Comment, type Display an
indication to the user. In the Message field, type The following form allows you to update
information or to register a new member. Set the Beep field to No. Set the Type field to
Information. For the Title, type Member Information.

3.  

Save and close the macro.4.  

In the Forms category, double-click the frmAccountTransactions form. Click the Update
Info button.

5.  
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8 - Getting Help In Microsoft Access:
Click the Office Assistant and type Create a macro.1.  

Click Create a macro.2.  

 

 

Switchboards
1 - Introduction:
To deliver your application and make it more functional, you need to provide a central point for
your users to choose and access the right component to do their job. That's the role of a
switchboard.

There are at least two common ways you can create or build a switchboard. You can use Microsoft
Access built-in features to build a switchboard, or you can design one from a form.

 

5 - Designing A Switchboard:
There are two formal ways you can get a switchboard in Microsoft Access. You can
design your own, or use the Switchboard Manager so that Microsoft Access will help
you create one.

To explore the Switchboard Manager, we will use three directories for our database.
The first directory (1) or dialog will be the main entrance of the database, the Main
Switchboard. It will allow the user to preview the read-only albums form or to view
the albums by categories. It will also allow the user to access another switchboard (2)
where the user will be lead to other forms on the database. The main switchboard will
also give access to another switchboard(3) that has a list of all the available reports.
The user will also be able to exit the whole database from the main switchboard. 

Start Microsoft Access and open the Music Collection8 database.1.  

In Microsoft Access 97, on the main menu, click Tools -> Add-Ins -> Switchboard
Manager. In MS AC2000, on the main menu, click Tools Database Utilities -> Switchboard
Manger. If you didn't have a switchboard yet, you will receive a message like the following:
  

    

2.  

Click Yes to create a new switchboard.3.  
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In the main dialog of Switchboard Manager, click the Edit button and change the name of
the Main Switchboard to 
Music Collection Database
  

  Click Close.

4.  

Click the New button and type Other Forms. Click OK. Click New, type Preview Reports
and click OK. Now that various switchboards have been created, we can edit the content of
each.

5.  

Double-click Music Collection Database (Default).6.  

In the Edit Switchboard Page dialog, click New and type View Albums Records, and press
Tab. In the Command combo box, choose Open Form In Edit Mode. In the Form combo
box, choose frmAlbumsView and click OK.
  

  

7.  

In the Edit Switchboard Page dialog, click New and type View Albums By Categories, and
press Tab. In the Command combo box, choose Open Form In Edit Mode. In the Form
combo box, choose fvwAlbumsCategories and click OK.

8.  

In the Edit Switchboard Page dialog, click New and type Access Other Forms, and press
Tab. Make sure the Commands combo box displays Go To Switchboard. In the Form
combo box, choose Other Forms, and click OK.

9.  

In the Edit Switchboard Page dialog, click New and type Preview Reports, and press Tab.
Make sure the Commands combo box displays Go To Switchboard. In the Form combo box,
choose Preview Reports, and click OK.

10.  

In the Edit Switchboard Page dialog, click New and type Exit The Music Collection
Database, and press Tab. In the Command combo box, choose Exit Application, and click
OK.

11.  

In the Edit Switchboard Page, click Close.12.  

In the Switchboard Manager, click Other Forms. Then click Edit.13.  

Change the Switchboard name to Access To Other Forms.14.  

Click New and type Edit Artists Names, and press Tab. In the Commands combo box,
choose Open Form In Edit Mode. In the Form combo box, choose frmArtists and click OK.

15.  
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Click New and type Edit Music Categories, and press Tab. In the Commands combo box,
choose Open Form In Edit Mode. In the Form combo box, choose frmMusicCategories and
click OK.

16.  

Click New and type Edit Albums Tracks, and press Tab. In the Commands combo box,
choose Open Form In Edit Mode. In the Form combo box, choose frmAlbumsTracks and
click OK.

17.  

Click New and type Edit Albums, and press Tab. In the Commands combo box, choose
Open Form In Edit Mode. In the Form combo box, choose frmEditAlbums and click OK.

18.  

Click New. In the Text box, type Return to Main Switchboard. Make sure the Command box
displays Go to Switchboard. In the Switchboard combo box, choose Music Collection
Database. Click OK and click Close.

19.  

Continue the same process to build and configure the Preview Report switch board. On the
Switchboard Manager, click Preview Reports. Make sure you provide a Return To Main
Switchboard.

20.  

When you have finished, close all switchboard dialogs.21.  

From the Database Window, click the Forms button, and double-click the Switchboard.22.  

You can make your switchboard always display at startup (when you start your application).
On the main menu, click Tools -> Startup...

23.  

In the Application Title box, type Music Collection. In the Display Form/Page combo box,
choose Switchboard. Click OK.

24.  

 

6 - Getting Help In Microsoft Access:
Click the Office Assistant and type Create a macro.1.  

Click Create a macro.2.  
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