Using Visual C++ .NET

Editing And Compiling In Microsoft Windows

This explains in detail the steps in creating a console program using VisualC++ .NET 2003, in either the IDE
mode or the command line mode.

Note that there are some convenient screen control functions in Borland's TurboC++ that are not supported in
VisualC++: randomize , random, gotoxy, and clrscr, so you will find replacements for these at the end of this
writeup.

Q 1. IDE Mode:

The "Hello, World" program is used here as an example. This may look complicated due to its length, but it's
not -- it's just very detailed. These instructions are designed for our lab situation, so that the student CPP files
are stored on the floppy drive. Otherwise, they risk losing files stored on the hard drive in the event that a reboot
is required. Also, VisualC++ uses nearly 1MB of "workspace” files, which are hard to manage on a floppy. So
these instructions tell how to put the workspace files on the hard drive, and the source files on the floppy. The
same instructions apply for other removable media, such as USB drives, except for the letter designation of the
drive.

Start Visual C++ .NET

The PCs in DVC's computer labs have Microsoft VisualC++ .NET installed on them. Using the mouse, click the
Windows Start
button (located in

[@ Microsoft OFfice

the lower left @ Motepad M Microsoft Visual Studio (WET 2003
corner Of the ) Metscape 7.1 #% Micrasoft Visual Studia NET 2003
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Open an Existing Project
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the computer screen shortly. Dynamic Help 2 x
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In the VisualC++ window, click Solution Explarer =
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Ready [ %

Using Visual Studio .NET 2003, page 1 of 7



In the popup "New
Project” window that
appears, select Visual
C++ Projects, and Win32 : —
I:l YWisual Basic Projecks

P Makefile MFZ Achees MFC s
Console Project. (27 visual C# Projects Froject o Application
] (2 visual J# Projects - i
Enter the "Location: +] 44 Wisual C++ Projects H %T % [g
C =y

New Project

Project Types: Templates:

c:\Windows\Desktop, or (23 Zetup and Deployment Projects F 57
in XP/2k, C:\Documents + (L] Other Projects MFC DLL MFC 1541
and Settings\All [ visual Studio Solutions Extension D

=1

Users\Desktop. Enter the
project “Name:" as

HelloWorld. (Note that & Console application tvpe of Win32 project. /\A

there are no spaces in the
word HelloWorld -- it is
two words run together Location: |C:'|,D|:u:ument5 and Settingsiall UsersiDeskiop Jﬂ Browse, ..
without a space.) Click
the OK button to proceed

to the “application FMore | i, | Cancel | Help |

wizard”.

ame: | Hellowtorld

Project will be created at C:\Documents and Settingstall Users)\DesktopiHelobyorld,

In the application
wizard window, click

Win32 Application Wizard - HelloWorld

the Application application Settings s

Settings link at the left. _ . o . o e
« Specify the tvpe of application wou will build with this project and the options or libraries vou

Check the Empty want supported,

project” option, and

click the Finish button. o
Application bype: Add support For:

(" Windows application Jui

The “Solution
Explorer” panel should
not appear on the
Visual C++ display.
Right-click over
“Source Files”, and
select Add->Add New
Item from the menu.

Application Settings f* Console application =

¥ Empky project
r
r s

(For adding a CPP that
already exists, use Add
Existing Item instead.)

Solution Explarer - HelloWorld B Finish Cancel Help
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[£5] References
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Select the floppy driv.e (or Add New ltern - HelloWorld
other removable media,

such as a USB drive E: as

B Categories:
shown in the example.)

&3

Templates:

Choose the C++ File +4 Wisual C++

template, and type the name
HelloWorld. Click the
Open button to complete
the process.

(Note: this places the CPP
file on your floppy diskette,
making it easy to save your
work, and protecting your
files from loss due to
unexpected reboot of the
Computer.) Creates a C++ source File,

wi (> JUE
=

Windows Form 4+ File HTIML Page

Marme: | Hellaworld]

Configure the Editor /I;

It is better to use spaces (as Location: | E:}

opposed to tabs) to ident
and align code, so that your

code looks the same in any

(.MET) (.opp) i, )
& |h]
Skatic Header File  Midl File {.idl)
Discovery ... r.h)
= (=
Resaurce File Server Module-Defi, ..
[.rcd Response ... File {,def)
Qpen Cancel | Help |

editor. To configure the

IDE’s editor to insert spaces when you press the TAB key, use
Tools->Options, and click the Tabs tab. Choose Text Eidtor->
C/C++->Tabs. Set the tab size and indent size both to 2 (or
another number of your liking), and select “Insert spaces”,
instead of “Keep tabs”. (To convert a file that already has tabs,
Use Edit->Select All and Edit->Advanced->Untabify Selection).

Type the Code for the Program

Using C++ language syntax, type your program into the window
titled HelloWorld.cpp . Type the following, with no indenting
on the first line of coding. Use 2-space indenting on the first
indented line. Skip single lines where indicated. There are three
different sets of enclosing symbols used -- the less-than and

(23 Environment - Indenting
(23 Source Contral ™ Mane
23 Text Editor  Elock
General o
[Z3 All Languages 2Mak
(3 Basic Tabs
23 Cic++ Tab size: 2
3ener
g Indent size: 2

Farmatting

[
[Z3 HTML ML z {+ Insert spaces

greater-than symbols around iostream, the parentheses after main, and the curly braces where indicated. Be
sure to use upper-case and lower-case lettering where shown.

Skark Page  HelloWorld.cpp® |

E #include <iostream:
using std::cout: int mainQ
L {

F] int main()

i
cout << "Hello, Worldin™: ¥
return 0O;

return O;

3
menu command.

#include <iostream>

cout << "Hello, World\n";

Save your work to the computer's floppy drive using the File->Save
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Compile and Run the Program

Press Ctrl-F7 to compile. If not successful, make corrections and repeat until successful. Press Ctrl--Shift- B
for a "full build", which includes linking, and if successful press F5 to run. You can also add cin.get(); to
suspend your program until a key is pressed -- otherwise, the DOS window disappears right away.

Distributing the Program
The compilation process creates an "executable™ file named HelloWorld.exe. Your program in its compiled
form will run on any Windows 95/98/ME/NT/2000/XP computer, whether or not that computer has VisualC++
or any other C++ compiler.

Window  Help
But before distributing HelloWorld.exe, you should create a "Release” o-
version of the program -- because the EXE file is smaller. To do so, A
use the pulldown menu on the toolbar, and change the selection from

Debug to Release. Then press Ctrl-Shift-B to rebuild -- this should Configuration Manager...
result in a new version of your EXE, located in a subfolder named
Release .

To run the executable, go to a command prompt (Start->All Programs->Accessories->Command Prompt) and
log into the drive and folder that contain the EXE file. Enter the name of the file, without the .exe filename
extension.

Managing Project Files

For backup purposes, all you need for
console programs are the source files
that you write — that is, the CPP (and H,
if any) files. When returning to the lab
for another editing session, create a new
project as you did originally, and add the
files to the project from your floppy

;#iqc1ude <jostreams
iusmg std::

int maing)

Savein | == USE MEMORY [E:]

cout << "

diskette. return 0 \ Darray
! :3 | arrayTemplate
To continue editing a project that My Fecent | |L)AutoCADZO00
remains on your hard drive from a Documents |2 AutoCAD2004
previous editing session, use the Open = :QC++
Project button on the opening screen of jé‘fﬂ”::::f”m
Visual C++, instead of the New Project Desktop _. s
button. Dieb14
/ |Z)MFcEley ator
O 2. Command Line Mode: o D;:;{n e | [EDsp200s
In order to use command line compiling, (DstudentFiles
first copy this file: o ) VisualPics
. 15 £l gen
. : . " T
C:\Program Files\Microsoft Visual My Computer ] Robert Burns
Studio .NET
2003\Vc7\bin\vcvars32.bat < !l S Pr—
.
...to your C:\WINDOWS folder. This by Metwork | Save as type: Text Documents [kt

has already been done on the computer
lab PCs, but it is renamed as vsvars32.bat, to distinguish it from the Visual C++ 6.0 version of this file.
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Use any text editor of your choosing, such as XP's Notepad, JNotePad, or Hesky-Data Pad. Then when you go
to a command prompt to compile and build, enter the command vcvars32 once to prepare for using the
command line editor.

When saving CPP files from Notepad, put the filename in quotes to prevent Windows from adding .txt to the
filename.

To compile, use a command like the following (the command is "see-el”, not "see-one™) to create an EXE file:

cl HelloWorld.cpp -EHs

¢ Command Prompt

Microsoft Windows BP [Version 5.1.26801
(C» Copyright 1985-2881 Microsoft Corp.

C:sxDocuments and Settingssdefault .DUGLFI
Setting environment for uwusing Microsoft =z tudio .MET 2883 tools.

CIf you have another verszion of Uiswal Studio or WViswal C++ dinstalled and wiszh
to wuse its tools from the command line,. »un vcocvars32.bat for that version.>

C:“Documents and Settings:default.DUCLA l

i ;s ﬁptlml“lng Compiler Uersion 13.10.3877 for BBxE6
ﬂupyrlght (ﬂ) Microsoft ﬂurpuratlun 19284-28082. All rights reserved.

HellolWorld.cpp
Microsoft (B> Incremental Linker Uersion 7.18.3877
Copyright <C> Microsoft Corporation. All rights reserved.

Aout tHelloWorld. exe
HellolWorld.ohj

To compile and build projects consisting of more than one CPP, list the CPPs separated by spaces, like this:

cl main.cpp Time.cpp -EHs

The EXE has the saim

naime as the Tirst (or only) listea CPP, but with the extension "exe". To run the program,
enter the name of the eco

ommand line -- you may leave off the trailing ".exe".

D
m®
P
i
@)
5
-t
:T

To compile a CPP without building, include the -c flag -- this produces an OBJ file with the same name as
the listed CPP, but with the extension "obj":

cl Time.cpp -c -EHs

To build an EXE from already-compiled OBJs, list the OBJs and do not use the -EHs flag, like this (creating
main.exe):

cl main.obj Time.obj
When working with multiple CPP files in a single project, it is recommended to compile each CPP separately,

using the -c flag during development. This makes debugging easier. Once the program is working, and you are
making small code adjustments, then you should go back to compiling and building all in one command.
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Using XP’s Command Line Buffer
So that you do not have to retype the compile and run commands, use the up and down arrow keys to navigate
through previously-typed commands. Use the F7 key to popup a list of commands in the buffer.

The usual sequence is to type the compile and build command, followed by the run command. After that , up-up
returns to the compile and build command, and down goes from there to the run command.

How To: Use randomize And random In Visual C++

Add the following code below the include statements and above int main(), so that the randomize() and
random() functions referenced in the text's code listing work in VisualC++.

#include <cstdlib>

#include <ctime>

#define randomize() (srand(time(0)))
#define random(x) (rand(Q) % x)

For example, call random(10) to get a randomly selected integer between 0 and 9, inclusive. The expression
(1 + random(6)) simulates the rolling of a 6-sided die. The expression (2 + random(6) + random(6))
simulates the rolling of two 6-sided dice. Every time you run your program you will get the same sequence of
random numbers, which is useful for debugging, but not so useful for the final product. Call randomize()
once in your program in order to get a new sequence every time your program runs. Usually this is the first
statement in the main function.
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How To: Use gotoxy And clrscr In Visual C++

TurboC++ has gotoxy and clrscr functions, which enable you to position the cursor on the screen (so that you
canput the contents of the next cout statement at a specific location) and to clear the screen. These functions do
not exist in VisualC++, but you can write them yourself. Here's a sample:

#include <iostream>
using namespace std;

#include <windows.h>
#include <process.h>

void gotoxy(int, int); // prototype
void clrscr(); // prototype

int mainQ)

{
// write text in 4 corners of the screen
clrscr(); // function call
gotoxy(10,10); // function call
cout << "at 10,10";
gotoxy(10,20); // function call
cout << "at 10,20";
gotoxy(20,10); // function call
cout << "at 20,10";
gotoxy(20,20); // function call
cout << "at 20,20";
return O;

}

// function definition -- requires windows.h
void gotoxy(int x, int y)

HANDLE hConsoleOutput;
COORD dwCursorPosition;

cout.flushQ;
dwCursorPosition.X = X;
dwCursorPosition.Y = y;
hConsoleOutput = GetStdHandle(STD_OUTPUT_HANDLE) ;
SetConsoleCursorPosition(hConsoleOutput,dwCursorPosition);

}

// Tunction definition -- requires process.h
void clrscrQ

{

system("'cls™);
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